summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2022-07-23 20:53:26 -0400
committerMithicSpirit2022-07-23 20:53:26 -0400
commit647a80189d2af63355f406c2ea6a0220f14fb286 (patch)
tree086ef15fe3cd29e5a2029c2b7f7c7437d0cd1ed3
parentdbbf58b199e384012545668d1c225232f98ed641 (diff)
downloadaur-647a80189d2af63355f406c2ea6a0220f14fb286.tar.gz
Build appflowy release instead
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55d0d3d0be5f..97c5a589cc8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,23 @@
_pkgname=appflowy
pkgname=$_pkgname-git
pkgver=latest
-pkgrel=4
+pkgrel=5
pkgdesc='An open-source alternative to Notion.'
arch=(x86_64)
url='https://www.appflowy.io/'
license=('AGPL3')
-depends=(gtk3 sqlite)
-makedepends=(git clang cmake ninja unzip rust cargo dart)
+depends=('glibc>=2.32' gtk3)
+makedepends=(git clang cmake ninja unzip rust cargo dart sqlite)
provides=($_pkgname)
conflicts=($_pkgname $_pkgname-bin)
replaces=()
backup=()
options=()
install=
-source=("$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
- 'flutter::git+https://github.com/flutter/flutter.git')
+source=(
+ "$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
+ 'flutter::git+https://github.com/flutter/flutter.git'
+)
sha256sums=('SKIP' 'SKIP')
_setpath() {
@@ -37,9 +39,6 @@ prepare() {
cd "$srcdir/$_pkgname/frontend"
sed -i "/rustup/d" scripts/makefile/env.toml
-
- cd "$srcdir/$_pkgname/frontend/app_flowy"
- flutter pub add charcode
}
build() {
@@ -49,8 +48,7 @@ build() {
cd "$srcdir/$_pkgname/frontend"
cargo make flowy_dev
- cargo make --profile production-linux-x86_64 flowy-sdk-release
- cargo make --profile production-linux-x86_64 appflowy-linux
+ cargo make --profile production-linux-x86_64 appflowy
}
package() {