summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2023-02-27 12:14:02 -0500
committerMithicSpirit2023-02-27 12:14:02 -0500
commitccf0cfd017ba59cacc748ed2f40f27be624fd6f7 (patch)
tree218a79734aeb6e372e2cb9ce107fc9bfebcd3870
parentdba90cc52cc5e243ff81224b912b7821c71a73e3 (diff)
downloadaur-ccf0cfd017ba59cacc748ed2f40f27be624fd6f7.tar.gz
Fix build
- Flutter install takes precendence over system flutter - Fixes issue with renamed paths now that tauri is becoming a thing. I will make the tauri package (probably just a split package here) soonTM.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2efffdc12b19..05fc6278231f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = appflowy-git
pkgdesc = An open-source alternative to Notion.
pkgver = latest
- pkgrel = 8
+ pkgrel = 9
url = https://www.appflowy.io/
arch = x86_64
license = AGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 7b549d33fe71..5da906a6d2b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=appflowy
pkgname=$_pkgname-git
pkgver=latest
-pkgrel=8
+pkgrel=9
pkgdesc='An open-source alternative to Notion.'
arch=(x86_64)
url='https://www.appflowy.io/'
@@ -16,14 +16,13 @@ replaces=()
backup=()
options=()
install=
-source=(
- "$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
- 'flutter::git+https://github.com/flutter/flutter.git#tag=3.3.10'
-)
-sha256sums=('SKIP' 'SKIP')
+source=("$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
+ 'flutter::git+https://github.com/flutter/flutter.git#tag=3.3.10')
+sha256sums=('SKIP'
+ 'SKIP')
_setpath() {
- PATH="$PATH:$srcdir/flutter/bin:$HOME/.pub-cache/bin:$HOME/.cargo/bin"
+ PATH="$srcdir/flutter/bin:$HOME/.pub-cache/bin:$HOME/.cargo/bin:$PATH"
}
pkgver() {
@@ -52,15 +51,14 @@ build() {
package() {
_setpath
- cd "$srcdir/$_pkgname/frontend/app_flowy/product/"*/linux/Release/AppFlowy
+ cd "$srcdir/$_pkgname/frontend/appflowy_flutter/product/"*/linux/Release/AppFlowy
install -dm755 "$pkgdir"{/usr/bin,/usr/share/applications,"/opt/$pkgname"}
cp -a * "$pkgdir/opt/$pkgname/"
rm "$pkgdir/opt/$pkgname/appflowy.desktop.temp"
- ln -s "/opt/$pkgname/app_flowy" "$pkgdir/usr/bin/"
+ ln -s "/opt/$pkgname/appflowy_flutter" "$pkgdir/usr/bin/"
_desktop_file="$pkgdir/usr/share/applications/AppFlowy.desktop"
install -m644 appflowy.desktop.temp "$_desktop_file"
- sed -i '/Exec=/s|\[CHANGE_THIS\]/AppFlowy|/usr/bin|' "$_desktop_file"
- sed -i "/Icon=/s|\[CHANGE_THIS\]/AppFlowy|/opt/$pkgname|" "$_desktop_file"
+ sed -i "s|\[CHANGE_THIS\]/AppFlowy|/opt/$pkgname|" "$_desktop_file"
}