summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2023-02-04 23:45:50 -0500
committerMithicSpirit2023-02-04 23:45:50 -0500
commitdba90cc52cc5e243ff81224b912b7821c71a73e3 (patch)
tree721437e4b725bc7d382214fd59c074a368b3825b
parentabe0089a77eac9e40c0e69aed661a7bb61be9d58 (diff)
downloadaur-dba90cc52cc5e243ff81224b912b7821c71a73e3.tar.gz
Fix build by hardcoding flutter version
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD5
3 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6bd92cc861e..2efffdc12b19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = appflowy-git
pkgdesc = An open-source alternative to Notion.
pkgver = latest
- pkgrel = 7
+ pkgrel = 8
url = https://www.appflowy.io/
arch = x86_64
license = AGPL3
@@ -21,7 +21,7 @@ pkgbase = appflowy-git
conflicts = appflowy
conflicts = appflowy-bin
source = appflowy::git+https://github.com/AppFlowy-IO/AppFlowy.git
- source = flutter::git+https://github.com/flutter/flutter.git
+ source = flutter::git+https://github.com/flutter/flutter.git#tag=3.3.10
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 277fba338ef3..167d5c3bc3e7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
-*
-**/*
+/*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 20256754902b..7b549d33fe71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=appflowy
pkgname=$_pkgname-git
pkgver=latest
-pkgrel=7
+pkgrel=8
pkgdesc='An open-source alternative to Notion.'
arch=(x86_64)
url='https://www.appflowy.io/'
@@ -18,7 +18,7 @@ options=()
install=
source=(
"$_pkgname::git+https://github.com/AppFlowy-IO/AppFlowy.git"
- 'flutter::git+https://github.com/flutter/flutter.git'
+ 'flutter::git+https://github.com/flutter/flutter.git#tag=3.3.10'
)
sha256sums=('SKIP' 'SKIP')
@@ -34,7 +34,6 @@ pkgver() {
prepare() {
_setpath
- flutter channel stable
flutter config --enable-linux-desktop
cd "$srcdir/$_pkgname/frontend"