summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredy García2022-02-08 20:54:45 -0500
committerFredy García2022-02-08 20:54:45 -0500
commit4235e536d150ff409eec555abacd28fbc8feabd2 (patch)
treed5d9cfe9468d031156ed4a7b7503d825a98b1adc
parent5f51fd6c138f2f8e371724ed8e700954a99c1160 (diff)
downloadaur-4235e536d150ff409eec555abacd28fbc8feabd2.tar.gz
Upgrading to version 5.5.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a21763e4cac0..8b12b3abe763 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = appgate-sdp
pkgdesc = Appgate SDP (Software Defined Perimeter) desktop client
- pkgver = 5.5.2
+ pkgver = 5.5.3
pkgrel = 1
url = https://www.appgate.com/support/software-defined-perimeter-support
arch = x86_64
license = custom
license = custom:commercial
- depends = dnsmasq
depends = gtk3
depends = libsecret
depends = libxss
@@ -15,13 +14,16 @@ pkgbase = appgate-sdp
depends = python-dbus
depends = python-distro
optdepends = gnome-keyring: saves the endpoint certificate between sessions
+ optdepends = dnsmasq: dns resolver for systems without systemd-resolved
provides = appgate-sdp
options = staticlibs
options = !strip
options = !emptydirs
- source = https://bin.appgate-sdp.com/5.5/client/appgate-sdp_5.5.2_amd64.deb
+ source = https://bin.appgate-sdp.com/5.5/client/appgate-sdp_5.5.3_amd64.deb
source = appgatedriver.service.patch
- sha256sums = f0aed1aa4c69c91b10dd01c621f4dc84b699efffa4d216e225d97bb9cfbebd8b
+ source = 10-appgate-tun.network
+ sha256sums = a92a38257fc98fe26479eb5920cc3cf0c2bb4b33a04fc68d6d06f2da427dd68a
sha256sums = 0789aa07d6a7af44187e407696d930e78c50370c19b8399722ebecb0655ffcdb
+ sha256sums = 2eb0daa10429e67d703cceccd34069da3044d99c5652658ec73c7a01c88b64e9
pkgname = appgate-sdp
diff --git a/PKGBUILD b/PKGBUILD
index 5579c3829ecb..9cf2eefd4938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
# Contributor: Pawel Mosakowski <pawel at mosakowski dot net>
pkgname=appgate-sdp
-pkgver=5.5.2
+pkgver=5.5.3
pkgrel=1
pkgdesc="Appgate SDP (Software Defined Perimeter) desktop client"
arch=("x86_64")
url="https://www.${pkgname%%-*}.com/support/software-defined-perimeter-support"
license=("custom" "custom:commercial")
-depends=("dnsmasq" "gtk3" "libsecret" "libxss" "nodejs" "nss" "python-dbus" "python-distro")
-optdepends=("dnsmasq: dns resolver for systems without systemd-resolved"
- "gnome-keyring: saves the endpoint certificate between sessions")
+depends=("gtk3" "libsecret" "libxss" "nodejs" "nss" "python-dbus" "python-distro")
+optdepends=(
+ "gnome-keyring: saves the endpoint certificate between sessions"
+ "dnsmasq: dns resolver for systems without systemd-resolved"
+)
provides=("${pkgname}")
options=(staticlibs !strip !emptydirs)
source=(
@@ -19,7 +21,7 @@ source=(
"10-appgate-tun.network"
)
sha256sums=(
- "f0aed1aa4c69c91b10dd01c621f4dc84b699efffa4d216e225d97bb9cfbebd8b"
+ "a92a38257fc98fe26479eb5920cc3cf0c2bb4b33a04fc68d6d06f2da427dd68a"
"0789aa07d6a7af44187e407696d930e78c50370c19b8399722ebecb0655ffcdb"
"2eb0daa10429e67d703cceccd34069da3044d99c5652658ec73c7a01c88b64e9"
)
@@ -43,6 +45,7 @@ package() {
# Install service files
install -dm755 "${pkgdir}/usr/lib/systemd/system"
install -Dm644 "${srcdir}/${pkgname}/lib/systemd/system/"* "${pkgdir}/usr/lib/systemd/system/"
+
# Make systemd-networkd not manage tun interfaces
install -dm755 "${pkgdir}/usr/lib/systemd/network"
install -Dm644 "${srcdir}/10-appgate-tun.network" "${pkgdir}/usr/lib/systemd/network/"