summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPawel Mosakowski2018-07-19 12:54:14 +0100
committerPawel Mosakowski2018-07-19 13:04:27 +0100
commit4d66e166bfcd9d805d242d02082c146e5af73d24 (patch)
treea4a5057991bf730ab42f6ea09cb45ef04fcbec7e
downloadaur-4d66e166bfcd9d805d242d02082c146e5af73d24.tar.gz
Initial release
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD47
-rw-r--r--appgatedriver.service29
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89d9cef2c809
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = appgate-sdp
+ pkgdesc = Software Defined Perimeter - GUI client
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://www.cyxtera.com/secure-access/appgate-sdp
+ arch = x86_64
+ license = custom
+ makedepends = dpkg
+ depends = gconf
+ depends = libsecret
+ depends = gtk3
+ depends = python
+ depends = nss
+ depends = libxss
+ depends = nodejs
+ depends = dnsmasq
+ conflicts = appgate-sdp-headless
+ noextract = appgate-sdp_4.1.0_amd64.deb
+ noextract = appgatedriver.service
+ source = https://sdpdownloads.cyxtera.com/files/download/AppGate-SDP-4.1.0/clients/appgate-sdp_4.1.0_amd64.deb
+ source = appgatedriver.service
+ md5sums = 424c3def083993c095e4bad0252cb848
+ md5sums = 002644116e20b2d79fdb36b7677ab4cf
+
+pkgname = appgate-sdp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86e26324d92f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Pawel Mosakowski <pawel@mosakowski.net>
+pkgname=appgate-sdp
+conflicts=('appgate-sdp-headless')
+pkgver=4.1.0
+pkgrel=1
+epoch=
+pkgdesc="Software Defined Perimeter - GUI client"
+arch=('x86_64')
+url="https://www.cyxtera.com/secure-access/appgate-sdp"
+license=('custom')
+# dependecies taken from provided Ubuntu package
+# depends=('alsa-lib' 'atk' 'cairo' 'cups' 'dbus' 'dnsmasq' 'expat' 'fontconfig' 'freetype2'
+# 'gcc-libs' 'gconf' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'iptables' 'libappindicator-gtk2'
+# 'libxcomposite' 'libsecret' 'libx11' 'libxcb' 'libxcursor' 'libxdamage' 'libxext'
+# 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nodejs' 'nspr' 'nss'
+# 'pango' 'procps-ng' 'python' 'python-dbus' 'python-distutils-extra' 'zlib')
+
+# dependecies calculated by namcap
+depends=('gconf' 'libsecret' 'gtk3' 'python' 'nss' 'libxss' 'nodejs' 'dnsmasq')
+makedepends=('dpkg')
+source=("https://sdpdownloads.cyxtera.com/files/download/AppGate-SDP-${pkgver}/clients/${pkgname}_${pkgver}_amd64.deb"
+ "appgatedriver.service")
+
+# don't unpack anything
+noextract=("${source[@]##*/}")
+
+prepare() {
+ dpkg -x "${pkgname}_${pkgver}_amd64.deb" "${pkgname}-${pkgver}"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cp -vr * "$pkgdir/"
+
+ mv -v "$pkgdir/lib/systemd/system" "$pkgdir/usr/lib/systemd/"
+ rm -vrf "$pkgdir/lib"
+
+ cp -v "$srcdir/appgatedriver.service" "$pkgdir/usr/lib/systemd/system/appgatedriver.service"
+
+ mkdir -vp "$pkgdir/usr/share/licenses/appgate-sdp"
+ cp -v "$pkgdir/usr/share/doc/appgate/copyright" "$pkgdir/usr/share/licenses/appgate-sdp"
+ cp -v "$pkgdir/usr/share/doc/appgate/LICENSE.github" "$pkgdir/usr/share/licenses/appgate-sdp"
+ cp -v "$pkgdir/usr/share/doc/appgate/LICENSES.chromium.html.bz2" "$pkgdir/usr/share/licenses/appgate-sdp"
+}
+
+md5sums=('424c3def083993c095e4bad0252cb848'
+ '002644116e20b2d79fdb36b7677ab4cf')
diff --git a/appgatedriver.service b/appgatedriver.service
new file mode 100644
index 000000000000..902db9a64f22
--- /dev/null
+++ b/appgatedriver.service
@@ -0,0 +1,29 @@
+[Unit]
+Description=AppGate driver service
+
+[Service]
+# Remove traces of appgate-resolver, if it wasn't terminated properly
+ExecStartPre=/bin/sh -c "test -e /etc/resolv.appgate && (chattr -i /etc/resolv.conf || :; mv /etc/resolv.appgate /etc/resolv.conf) ||:"
+ExecStart="/opt/appgate/tun-service"
+Type=forking
+Restart=always
+ProtectHome=true
+ProtectKernelTunables=true
+ProtectKernelModules=true
+ProtectControlGroups=true
+PrivateTmp=true
+CapabilityBoundingSet=~CAP_SYS_ADMIN
+CapabilityBoundingSet=~CAP_WAKE_ALARM
+CapabilityBoundingSet=~CAP_SYSLOG
+CapabilityBoundingSet=~CAP_SYS_TTY_CONFIG
+CapabilityBoundingSet=~CAP_SYS_TIME
+CapabilityBoundingSet=~CAP_SYS_RESOURCE
+CapabilityBoundingSet=~CAP_SYS_PTRACE
+CapabilityBoundingSet=~CAP_SYS_PACCT
+CapabilityBoundingSet=~CAP_SYS_MODULE
+CapabilityBoundingSet=~CAP_SYS_CHROOT
+CapabilityBoundingSet=~CAP_SYS_BOOT
+InaccessiblePaths=-/mnt -/srv -/boot -/media
+
+[Install]
+WantedBy=multi-user.target