summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPawel Mosakowski2020-03-17 14:29:14 +0000
committerPawel Mosakowski2020-03-17 14:29:14 +0000
commitda4dd0e536898c660a3fb9e77dc0ec3640ef291f (patch)
tree9be611c4c03bd829f076a658d0ed340009aa791e
downloadaur-da4dd0e536898c660a3fb9e77dc0ec3640ef291f.tar.gz
Initial update. Version 5.0.3
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
-rw-r--r--appgatedriver.service29
-rw-r--r--nm.py.patch15
5 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfe6d640ea81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = appgate-sdp-5
+ pkgdesc = Software Defined Perimeter v5 - GUI client
+ pkgver = 5.0.3
+ pkgrel = 1
+ url = https://www.cyxtera.com/essential-defense/appgate-sdp/support
+ arch = x86_64
+ license = custom
+ depends = gconf
+ depends = libsecret
+ depends = gtk3
+ depends = python
+ depends = nss
+ depends = libxss
+ depends = nodejs
+ depends = dnsmasq
+ conflicts = appgate-sdp-headless
+ conflicts = appgate-sdp
+ options = staticlibs
+ source = https://sdpdownloads.cyxtera.com/AppGate-SDP-5.0/clients/appgate-sdp_5.0.3_amd64.deb
+ source = appgatedriver.service
+ source = nm.py.patch
+ md5sums = 1ffc310a4aea80fb8574f7d3eaa611ec
+ md5sums = 002644116e20b2d79fdb36b7677ab4cf
+ md5sums = c36c11d995cc341f2f1eb4c3b6afa732
+
+pkgname = appgate-sdp-5
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..94bf332abe8d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.deb
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11d2d4be6e7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Pawel Mosakowski <pawel at mosakowski dot net>
+pkgname=appgate-sdp-5
+conflicts=('appgate-sdp-headless' 'appgate-sdp')
+pkgver=5.0.3
+_download_pkgver=$(expr match "$pkgver" '\([[:digit:]]\+\.[[:digit:]]\+\)')
+_download_pkgname='appgate-sdp'
+pkgrel=1
+epoch=
+pkgdesc="Software Defined Perimeter v5 - GUI client"
+arch=('x86_64')
+url="https://www.cyxtera.com/essential-defense/appgate-sdp/support"
+license=('custom')
+
+# dependecies calculated by namcap
+depends=('gconf' 'libsecret' 'gtk3' 'python' 'nss' 'libxss' 'nodejs' 'dnsmasq')
+source=("https://sdpdownloads.cyxtera.com/AppGate-SDP-${_download_pkgver}/clients/${_download_pkgname}_${pkgver}_amd64.deb"
+ "appgatedriver.service"
+ "nm.py.patch")
+
+options=(staticlibs)
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ cp -dpr "${srcdir}"/{etc,lib,opt,usr} "${pkgdir}"
+ mv -v "$pkgdir/lib/systemd/system" "$pkgdir/usr/lib/systemd/"
+ rm -vrf "$pkgdir/lib"
+
+ cp -v "$srcdir/appgatedriver.service" "$pkgdir/usr/lib/systemd/system/appgatedriver.service"
+ patch "$pkgdir/opt/appgate/linux/nm.py" "$srcdir/nm.py.patch"
+
+ mkdir -vp "$pkgdir/usr/share/licenses/appgate-sdp"
+ cp -v "$pkgdir/usr/share/doc/appgate/copyright" "$pkgdir/usr/share/licenses/appgate-sdp"
+ cp -v "$pkgdir/usr/share/doc/appgate/LICENSE.github" "$pkgdir/usr/share/licenses/appgate-sdp"
+ cp -v "$pkgdir/usr/share/doc/appgate/LICENSES.chromium.html.bz2" "$pkgdir/usr/share/licenses/appgate-sdp"
+}
+md5sums=('1ffc310a4aea80fb8574f7d3eaa611ec'
+ '002644116e20b2d79fdb36b7677ab4cf'
+ 'c36c11d995cc341f2f1eb4c3b6afa732')
diff --git a/appgatedriver.service b/appgatedriver.service
new file mode 100644
index 000000000000..902db9a64f22
--- /dev/null
+++ b/appgatedriver.service
@@ -0,0 +1,29 @@
+[Unit]
+Description=AppGate driver service
+
+[Service]
+# Remove traces of appgate-resolver, if it wasn't terminated properly
+ExecStartPre=/bin/sh -c "test -e /etc/resolv.appgate && (chattr -i /etc/resolv.conf || :; mv /etc/resolv.appgate /etc/resolv.conf) ||:"
+ExecStart="/opt/appgate/tun-service"
+Type=forking
+Restart=always
+ProtectHome=true
+ProtectKernelTunables=true
+ProtectKernelModules=true
+ProtectControlGroups=true
+PrivateTmp=true
+CapabilityBoundingSet=~CAP_SYS_ADMIN
+CapabilityBoundingSet=~CAP_WAKE_ALARM
+CapabilityBoundingSet=~CAP_SYSLOG
+CapabilityBoundingSet=~CAP_SYS_TTY_CONFIG
+CapabilityBoundingSet=~CAP_SYS_TIME
+CapabilityBoundingSet=~CAP_SYS_RESOURCE
+CapabilityBoundingSet=~CAP_SYS_PTRACE
+CapabilityBoundingSet=~CAP_SYS_PACCT
+CapabilityBoundingSet=~CAP_SYS_MODULE
+CapabilityBoundingSet=~CAP_SYS_CHROOT
+CapabilityBoundingSet=~CAP_SYS_BOOT
+InaccessiblePaths=-/mnt -/srv -/boot -/media
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nm.py.patch b/nm.py.patch
new file mode 100644
index 000000000000..ddb842f3dc8b
--- /dev/null
+++ b/nm.py.patch
@@ -0,0 +1,15 @@
+--- ./opt/appgate/linux/nm.py.before 2020-03-17 11:43:13.875718603 +0000
++++ ./opt/appgate/linux/nm.py 2020-03-17 11:44:42.565719740 +0000
+@@ -271,8 +271,10 @@
+ if _bus_exists('uk.org.thekelleys.dnsmasq', '/'):
+ syslog(LOG_INFO, '[has_system_dnsmasq] dnsmasq bus present')
+ return True
+-
+- if platform.linux_distribution()[0] != 'Fedora':
++
++ # this is PKGBUILD for Arch so this check should always yield True
++ # if platform.linux_distribution()[0] != 'Fedora':
++ if True:
+ try:
+ bus = dbus.SystemBus()
+ proxy = bus.get_object(