summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:19:57 +0200
committerM0Rf302015-06-17 15:19:57 +0200
commit46c5fb8bda993ccb2589d17591ef3dba13708436 (patch)
tree508d904fd84ede5b4274590b865bd40646ea2ada
downloadaur-46c5fb8bda993ccb2589d17591ef3dba13708436.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD23
-rw-r--r--appglass.install3
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83d9f068d627
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = appglass
+ pkgdesc = A lightweight application Launcher for GNU/Linux
+ pkgver = 1.0
+ pkgrel = 2
+ url = https://github.com/kumarasinghe/appglass/
+ install = appglass.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gambas3-runtime
+ depends = gambas3-gb-desktop
+ depends = gambas3-gb-form
+ depends = gambas3-gb-image
+ depends = gambas3-gb-qt4
+ depends = gambas3-gb-qt4-opengl
+ depends = gambas3-gb-opengl
+ depends = findutils
+ depends = coreutils
+ depends = wget
+ depends = mplayer
+ depends = imagemagick
+ depends = xdg-utils
+ depends = xterm
+ depends = bash
+ depends = xorg-xprop
+ depends = xcompmgr
+ conflicts = appglass-git
+ source = https://github.com/kumarasinghe/appglass/archive/1.0.tar.gz
+ md5sums = 0fa5ff776108909464235438779d7e4b
+
+pkgname = appglass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8cffa7eedac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Maintainer: M0Rf30
+
+pkgname=appglass
+pkgver=1.0
+pkgrel=2
+pkgdesc="A lightweight application Launcher for GNU/Linux"
+arch=('i686' 'x86_64')
+url="https://github.com/kumarasinghe/appglass/"
+license=('GPL3')
+depends=('gambas3-runtime' 'gambas3-gb-desktop' 'gambas3-gb-form' 'gambas3-gb-image' 'gambas3-gb-qt4'
+ 'gambas3-gb-qt4-opengl' 'gambas3-gb-opengl' 'findutils' 'coreutils' 'wget' 'mplayer' 'imagemagick' 'xdg-utils'
+ 'xterm' 'bash' 'xorg-xprop' 'xcompmgr')
+conflicts=('appglass-git')
+install=appglass.install
+source=("https://github.com/kumarasinghe/$pkgname/archive/$pkgver.tar.gz")
+
+package(){
+ cd $pkgname-$pkgver
+ cd installer
+ tar -xvzf root.tar.gz -C $pkgdir
+}
+
+md5sums=('0fa5ff776108909464235438779d7e4b')
diff --git a/appglass.install b/appglass.install
new file mode 100644
index 000000000000..3402226d52d9
--- /dev/null
+++ b/appglass.install
@@ -0,0 +1,3 @@
+post_install () {
+ xdg-desktop-menu forceupdate
+} \ No newline at end of file