summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNixuge2023-01-29 22:57:33 +0100
committerNixuge2023-01-29 22:57:33 +0100
commit7c91d955370bb6800e3394c215e7567fc7c39059 (patch)
treef40825504fbfa008900a333cb929a684be457d2a
downloadaur-7c91d955370bb6800e3394c215e7567fc7c39059.tar.gz
Initial commit (1.1.1)
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9665eb5d6e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = appimage-builder-bin
+ pkgdesc = GNU/Linux packaging solution using the AppImage format
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/AppImageCrafters/appimage-builder
+ arch = x86_64
+ license = MIT
+ depends = binutils
+ depends = desktop-file-utils
+ depends = fakeroot
+ depends = gdk-pixbuf2
+ depends = patchelf
+ depends = python-pip
+ depends = python-setuptools
+ depends = squashfs-tools
+ depends = strace
+ depends = wget
+ depends = zsync
+ options = !strip
+ source = https://github.com/AppImageCrafters/appimage-builder/releases/download/Continuous/appimage-builder-1.1.1.dev32+g2709a3b-x86_64.AppImage
+ sha256sums = 7569b710262a42de0d577ece8bfd0b917e9fdbd4a8d0437c29c635b0eaddd7bf
+
+pkgname = appimage-builder-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dd0469fe6c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Nixuge
+
+pkgname=appimage-builder-bin
+_pkgname=appimage-builder
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='GNU/Linux packaging solution using the AppImage format'
+url=https://github.com/AppImageCrafters/appimage-builder
+arch=(x86_64)
+license=(MIT)
+depends=("binutils" "desktop-file-utils" "fakeroot" "gdk-pixbuf2" "patchelf" "python-pip" "python-setuptools" "squashfs-tools" "strace" "wget" "zsync")
+options=(!strip)
+_tag="Continuous"
+_appimage="appimage-builder-1.1.1.dev32+g2709a3b-x86_64.AppImage"
+_desktop="org.appimage-crafters.appimage-builder.desktop"
+source=("https://github.com/AppImageCrafters/appimage-builder/releases/download/${_tag}/${_appimage}")
+sha256sums=('7569b710262a42de0d577ece8bfd0b917e9fdbd4a8d0437c29c635b0eaddd7bf')
+
+
+package() {
+ # AppImage
+ install -Dm755 \
+ "${srcdir}/${_appimage}" \
+ "${pkgdir}/opt/${_pkgname}/${_pkgname}.AppImage"
+
+ # Skipping desktop & icon since those don't make sense
+ # for a tool like this
+
+ # Desktop file
+ # install -Dm644 \
+ # "${srcdir}/squashfs-root/${_desktop}" \
+ # "${pkgdir}/usr/share/applications/${_desktop}"
+
+ # Icon images
+ # install -dm755 "${pkgdir}/usr/share/"
+ # cp -a \
+ # "${srcdir}/squashfs-root/usr/share/icons" \
+ # "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s \
+ "/opt/${_pkgname}/${_pkgname}.AppImage" \
+ "${pkgdir}/usr/bin/${_pkgname}"
+}