summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-05-31 10:10:50 +0200
committerwillemw122021-05-31 10:10:50 +0200
commit680c7d7c4c7e45d291b649b4fb42e2280f650fbb (patch)
treebb032635a366ca01f002096e97a7f8bd692ef79b
downloadaur-680c7d7c4c7e45d291b649b4fb42e2280f650fbb.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffbd2f5a8c4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = appimage-cli-tool-git
+ pkgdesc = AppImage package manager CLI
+ pkgver = 0.1.4.r0.gc3fcae5
+ pkgrel = 1
+ url = https://github.com/AppImageCrafters/appimage-cli-tool
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ provides = appimage-cli-tool
+ conflicts = appimage-cli-tool
+ options = !strip
+ options = !emptydirs
+ source = appimage-cli-tool-git::git+https://github.com/AppImageCrafters/appimage-cli-tool.git
+ md5sums = SKIP
+
+pkgname = appimage-cli-tool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e748fdaf9ed8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+pkgname=appimage-cli-tool-git
+pkgver=0.1.4.r0.gc3fcae5
+pkgrel=1
+pkgdesc="AppImage package manager CLI"
+arch=('x86_64')
+url="https://github.com/AppImageCrafters/appimage-cli-tool"
+license=('MIT')
+makedepends=('git' 'go')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!strip' '!emptydirs')
+source=($pkgname::git+$url.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+#prepare(){
+# cd $pkgname
+# mkdir -p build/
+#}
+
+build() {
+ cd $pkgname
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export GOPATH="$srcdir/build"
+ go get -v -t -d ./...
+ #go build -o "$GOPATH" -v ./...
+ go install -v ./...
+}
+
+package() {
+ #install -Dm755 build/cmd "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm755 build/bin/cmd "$pkgdir/usr/bin/${pkgname%-git}"
+}
+