summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMazhar Hussain2023-12-26 10:20:37 +0500
committerMazhar Hussain2023-12-26 10:20:37 +0500
commit651997c825fb90a41561e9e571639fa235435888 (patch)
tree57e989b6d39826caeffae5de738469208c859edb
parent436d61616930ff03df9d60fdf0bb975549ca2b89 (diff)
downloadaur-651997c825fb90a41561e9e571639fa235435888.tar.gz
Add a LICENSE file & Fix file-permissions of directories
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD20
3 files changed, 48 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0e02b6055ed..e80c1ae8b175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = appimaged-bin
pkgdesc = Deprecated: A daemon that monitors the system and integrates AppImages
pkgver = r199
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AppImageCommunity/appimaged
arch = x86_64
license = MIT
depends = gdk-pixbuf2
source = appimaged.AppImage::https://github.com/AppImageCommunity/appimaged/releases/download/continuous/appimaged-x86_64.AppImage
+ source = LICENSE::https://github.com/AppImageCommunity/appimaged/raw/continuous/LICENSE
sha256sums = 0cb439698ccd542c622c5aec5496efb0fe6a56575b16be9e77bd5467b97b4555
+ sha256sums = b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94
pkgname = appimaged-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..01559aaf067e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+MIT License
+
+If not stated otherwise within the individual file or subdirectory, the
+original source code in this repository is licensed as below. This does not
+necessarily apply for all dependencies. For the sake of clarity, this license
+does NOT apply to the contents of AppImages that anyone may create.
+Software contained inside an AppImage may be licensed under any license at the
+discretion of the respecive rights holder(s).
+
+Copyright (c) 2004-18 Simon Peter
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index acf5aec2b06c..8d44a06893d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,18 @@ pkgname=appimaged-bin
pkgdesc="Deprecated: A daemon that monitors the system and integrates AppImages"
url="https://github.com/AppImageCommunity/appimaged"
pkgver=r199
-pkgrel=1
+pkgrel=2
arch=(x86_64)
license=(MIT)
depends=(gdk-pixbuf2)
-source=("appimaged.AppImage"::"https://github.com/AppImageCommunity/appimaged/releases/download/continuous/appimaged-x86_64.AppImage")
-sha256sums=(0cb439698ccd542c622c5aec5496efb0fe6a56575b16be9e77bd5467b97b4555)
+source=(
+ "appimaged.AppImage"::"https://github.com/AppImageCommunity/appimaged/releases/download/continuous/appimaged-x86_64.AppImage"
+ "LICENSE"::"https://github.com/AppImageCommunity/appimaged/raw/continuous/LICENSE"
+)
+sha256sums=(
+ 0cb439698ccd542c622c5aec5496efb0fe6a56575b16be9e77bd5467b97b4555
+ b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94
+)
prepare() {
chmod +x appimaged.AppImage
@@ -19,5 +25,13 @@ package() {
./appimaged.AppImage --appimage-extract "${pattern}"
done
+ for directory in $(find squashfs-root -type d); do
+ chmod 755 "${directory}"
+ rmdir --parents --ignore-fail-on-non-empty "${directory}"
+ done
+
mv -fT squashfs-root "${pkgdir}"
+
+ mkdir --parents "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp LICENSE --target-directory "${pkgdir}/usr/share/licenses/${pkgname}"
}