summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2019-04-11 01:20:10 +0200
committerBernhard Landauer2019-04-11 01:20:10 +0200
commitf4c421a780d6f2a878ec430d76b8ebdf72fdb171 (patch)
tree8b66b7505aa652d8f620f1bafa0aae640776d73c
downloadaur-f4c421a780d6f2a878ec430d76b8ebdf72fdb171.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD47
-rw-r--r--appimage-binfmt-remove.hook10
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a2e4f224023
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = appimagelauncher
+ pkgdesc = A Helper application for running and integrating AppImages.
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/TheAssassin/AppImageLauncher
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = wget
+ makedepends = vim
+ makedepends = qt5-tools
+ depends = binutils
+ depends = boost
+ depends = cairo
+ depends = desktop-file-utils
+ depends = fuse
+ depends = gtest
+ depends = libarchive
+ depends = libbsd
+ depends = qt5-base
+ depends = shared-mime-info
+ conflicts = appimagelauncher-git
+ source = git+https://github.com/TheAssassin/AppImageLauncher.git#tag=v1.2.2
+ source = appimage-binfmt-remove.hook
+ sha256sums = SKIP
+ sha256sums = 72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81
+
+pkgname = appimagelauncher
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ecb6078f4f4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+AppImageLauncher/*
+src/* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..652a1523296d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# sMaintainer: Bernhard Landauer <bernhard@manjaro.org>
+# Maintainer: James Kittsmiller (AJSlye) <james@nulogicsystems.com>
+
+_pkgname=AppImageLauncher
+pkgname=appimagelauncher
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A Helper application for running and integrating AppImages."
+arch=('x86_64')
+url="https://github.com/TheAssassin/AppImageLauncher"
+license=('MIT')
+depends=('binutils'
+ 'boost'
+ 'cairo'
+ 'desktop-file-utils'
+ 'fuse'
+ 'gtest'
+ 'libarchive'
+ 'libbsd'
+ 'qt5-base'
+ 'shared-mime-info')
+makedepends=('git' 'cmake' 'wget' 'vim' 'qt5-tools')
+conflicts=('appimagelauncher-git')
+source=("git+$url.git#tag=v$pkgver"
+ 'appimage-binfmt-remove.hook')
+sha256sums=('SKIP'
+ '72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81')
+
+prepare() {
+ cd $_pkgname
+ git submodule update --init --recursive
+}
+
+build() {
+ cd $_pkgname
+ cmake . -DCMAKE_INSTALL_PREFIX:PATH=/usr/ -DUSE_SYSTEM_GTEST=ON -DUSE_SYSTEM_XZ=ON \
+ -DUSE_SYSTEM_LIBARCHIVE=ON
+ make
+}
+
+package() {
+ install -Dm644 -t $pkgdir/usr/share/libalpm/hooks *.hook
+
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/appimage-binfmt-remove.hook b/appimage-binfmt-remove.hook
new file mode 100644
index 000000000000..d96fd30cf9c0
--- /dev/null
+++ b/appimage-binfmt-remove.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = File
+Operation = Remove
+Target = usr/lib/binfmt.d/appimage.conf
+
+[Action]
+Description = Unregistering appimage binary format...
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/systemd-hook binfmt
+NeedsTargets