summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornulogicsystems2018-04-27 22:58:31 -0400
committernulogicsystems2018-04-27 22:58:31 -0400
commit09ad87aebcc1ded9f76d349a08042b90099dbb48 (patch)
tree4df603a7c581e619838a1eb35db43cd3a090235d
parent15ce70f84c608e598970d5e440d40f49dee33e3f (diff)
downloadaur-09ad87aebcc1ded9f76d349a08042b90099dbb48.tar.gz
Modifications
Actually remove the install file Add pacman hook to remove appimage binfmt upon package removal (install and upgrade are handle by upstream systemd-binfmt.hook)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--appimage-binfmt-remove.hook10
-rw-r--r--appimagelauncher.install9
4 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c74b7218614..2b71ce36e626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = appimagelauncher-git
pkgdesc = A Helper application for running and integrating AppImages.
- pkgver = 1alpha+git20180425.e530df7
+ pkgver = 1alpha+git20180428.44f5a67
pkgrel = 1
url = https://github.com/TheAssassin/AppImageLauncher
- install = appimagelauncher.install
arch = x86_64
license = MIT
makedepends = git
@@ -19,7 +18,9 @@ pkgbase = appimagelauncher-git
depends = inotify-tools
depends = libarchive
source = git://github.com/TheAssassin/AppImageLauncher#tag=continuous
+ source = appimage-binfmt-remove.hook
sha256sums = SKIP
+ sha256sums = 72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81
pkgname = appimagelauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index e9543705027f..3583409fa5f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=AppImageLauncher
pkgname=appimagelauncher-git
-pkgver=1alpha+git20180426.f3349e5
+pkgver=1alpha+git20180428.44f5a67
pkgrel=1
pkgdesc="A Helper application for running and integrating AppImages."
arch=('x86_64')
@@ -11,8 +11,10 @@ url="https://github.com/TheAssassin/AppImageLauncher"
license=('MIT')
depends=('qt5-base' 'fuse' 'cairo' 'binutils' 'desktop-file-utils' 'shared-mime-info' 'inotify-tools' 'libarchive')
makedepends=('git' 'cmake' 'wget' 'vim')
-source=("git://github.com/TheAssassin/$_pkgname#tag=continuous")
-sha256sums=('SKIP')
+source=("git://github.com/TheAssassin/$_pkgname#tag=continuous"
+ 'appimage-binfmt-remove.hook')
+sha256sums=('SKIP'
+ '72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -41,4 +43,9 @@ package() {
# install license files
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd "$srcdir"
+
+ # Install pacman hook
+ install -Dm644 -t "$pkgdir"/usr/share/libalpm/hooks *.hook
}
diff --git a/appimage-binfmt-remove.hook b/appimage-binfmt-remove.hook
new file mode 100644
index 000000000000..d96fd30cf9c0
--- /dev/null
+++ b/appimage-binfmt-remove.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = File
+Operation = Remove
+Target = usr/lib/binfmt.d/appimage.conf
+
+[Action]
+Description = Unregistering appimage binary format...
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/systemd-hook binfmt
+NeedsTargets
diff --git a/appimagelauncher.install b/appimagelauncher.install
deleted file mode 100644
index c9f85b2a9ab9..000000000000
--- a/appimagelauncher.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo "Installing AppImageLauncher as interpreter for AppImages"
- (set -x; update-binfmts --package appimage --install appimage-type2 /usr/bin/AppImageLauncher --magic 'AI\x02' --offset 8)
-}
-
-pre_remove() {
- echo "Removing AppImageLauncher as interpreter for AppImages"
- (set -x; update-binfmts --package appimage --remove appimage-type2 /usr/bin/AppImageLauncher)
-}