summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornulogicsystems2018-04-24 10:07:36 -0400
committernulogicsystems2018-04-24 10:07:36 -0400
commit4d20ce988c5e9ca2ef6a71cb77af061b55765646 (patch)
tree61d7a4adcf403713c4b7120219daca7ac4ea7306
downloadaur-4d20ce988c5e9ca2ef6a71cb77af061b55765646.tar.gz
Initial Commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de04544ef3a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = appimagelauncher-git
+ pkgdesc = A Helper application for running and integrating AppImages.
+ pkgver = 1alpha+git20180413.08ff6b8
+ pkgrel = 1
+ url = https://github.com/TheAssassin/AppImageLauncher
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = wget
+ makedepends = vim
+ depends = qt5-base
+ depends = fuse
+ depends = cairo
+ depends = binutils
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = inotify-tools
+ depends = libarchive
+ source = AppImageLauncher::git+https://github.com/TheAssassin/AppImageLauncher
+ sha256sums = SKIP
+
+pkgname = appimagelauncher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..381686bde215
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: James Kittsmiller (AJSlye) <james@kittsmiller.com>
+
+_pkgname=AppImageLauncher
+pkgname=appimagelauncher-git
+pkgver=1alpha+git20180413.08ff6b8
+pkgrel=1
+pkgdesc="A Helper application for running and integrating AppImages."
+arch=('x86_64')
+url="https://github.com/TheAssassin/AppImageLauncher"
+license=('MIT')
+depends=('qt5-base' 'fuse' 'cairo' 'binutils' 'desktop-file-utils' 'shared-mime-info' 'inotify-tools' 'libarchive')
+makedepends=('git' 'cmake' 'wget' 'vim')
+source=("$_pkgname::git+https://github.com/TheAssassin/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ printf "1alpha+git`date +%Y%m%d -u -d "$(git show -s --format=%ci $(git rev-parse HEAD))"`.%s" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ cmake . -DCMAKE_INSTALL_PREFIX:PATH=/usr/ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+
+ # install license files
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}