summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2019-07-16 00:25:00 +0200
committerFabioLolix2019-07-16 00:25:00 +0200
commite96279905bdeaaf3f97633b4b318a40d1cd36dd9 (patch)
treeb4d5ba21a15d3492a0fca6791620044c1ec370ef
parentbbd871435f52d5e2a63c0290c4fd6c9f1b2bc5fb (diff)
downloadaur-e96279905bdeaaf3f97633b4b318a40d1cd36dd9.tar.gz
revision 1
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD88
2 files changed, 90 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 111fbe14ff5b..dca21aabddf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,41 @@
pkgbase = appimagelauncher-git
pkgdesc = A Helper application for running and integrating AppImages.
- pkgver = 1alpha+git20180508.f871b20
+ pkgver = r760.6ce8449
pkgrel = 1
url = https://github.com/TheAssassin/AppImageLauncher
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = wget
- makedepends = vim
+ makedepends = extra-cmake-modules
+ makedepends = xxd
makedepends = qt5-tools
+ makedepends = wget
+ makedepends = boost
+ makedepends = gtest
depends = qt5-base
depends = fuse
- depends = cairo
- depends = binutils
- depends = desktop-file-utils
- depends = shared-mime-info
- depends = inotify-tools
- depends = libarchive
- depends = libbsd
- depends = boost
- source = git://github.com/TheAssassin/AppImageLauncher#tag=continuous
+ source = git+https://github.com/TheAssassin/AppImageLauncher.git
+ source = git+https://github.com/AppImage/AppImageUpdate.git
+ source = git+https://github.com/AppImage/libappimage.git
+ source = git+https://github.com/TheAssassin/zsync2
+ source = git+https://github.com/TheAssassin/fltk-1.3.4
+ source = git+https://github.com/TheAssassin/libdesktopenvironments
+ source = git+https://github.com/arsenm/sanitizers-cmake
+ source = git+https://github.com/google/googletest.git
+ source = git+https://github.com/AppImage/cpr
+ source = git+https://github.com/Taywee/args
source = appimage-binfmt-remove.hook
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81
pkgname = appimagelauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index 567c9dac5758..3d2d99fb0d04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,97 @@
-# $Id$
-# Maintainer: James Kittsmiller (AJSlye) <james@nulogicsystems.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: James Kittsmiller (AJSlye) <james@nulogicsystems.com>
+# Contributor: TheAssassin
_pkgname=AppImageLauncher
pkgname=appimagelauncher-git
-pkgver=1alpha+git20180508.f871b20
+pkgver=r760.6ce8449
pkgrel=1
pkgdesc="A Helper application for running and integrating AppImages."
arch=('x86_64')
url="https://github.com/TheAssassin/AppImageLauncher"
license=('MIT')
-depends=('qt5-base' 'fuse' 'cairo' 'binutils' 'desktop-file-utils' 'shared-mime-info' 'inotify-tools' 'libarchive' 'libbsd' 'boost')
-makedepends=('git' 'cmake' 'wget' 'vim' 'qt5-tools')
-source=("git://github.com/TheAssassin/$_pkgname#tag=continuous"
+depends=(qt5-base fuse)
+makedepends=(git cmake extra-cmake-modules xxd qt5-tools wget boost gtest)
+source=("git+https://github.com/TheAssassin/AppImageLauncher.git"
+ "git+https://github.com/AppImage/AppImageUpdate.git"
+ "git+https://github.com/AppImage/libappimage.git"
+ "git+https://github.com/TheAssassin/zsync2"
+ "git+https://github.com/TheAssassin/fltk-1.3.4"
+ "git+https://github.com/TheAssassin/libdesktopenvironments"
+ "git+https://github.com/arsenm/sanitizers-cmake"
+ "git+https://github.com/google/googletest.git"
+ "git+https://github.com/AppImage/cpr"
+ "git+https://github.com/Taywee/args"
'appimage-binfmt-remove.hook')
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81')
pkgver() {
cd "$srcdir/$_pkgname"
-
- printf "1alpha+git`date +%Y%m%d -u -d "$(git show -s --format=%ci $(git rev-parse HEAD))"`.%s" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "$srcdir/$_pkgname"
+ git submodule init
+ git config submodule.lib/AppImageUpdate.url "${srcdir}/AppImageUpdate"
+ git config submodule.lib/libappimage.url "${srcdir}/libappimage"
+ git submodule update
+
+ cd "$srcdir/$_pkgname/lib/AppImageUpdate"
+ git submodule init
+ git config submodule.lib/zsync2.url "${srcdir}/zsync2"
+ git config submodule.lib/fltk.url "${srcdir}/fltk-1.3.4"
+ git config submodule.lib/libdesktopenvironments.url "${srcdir}/libdesktopenvironments"
+ git config submodule.lib/--force.url "${srcdir}/sanitizers-cmake"
+ git config submodule.lib/sanitizers-cmake.url "${srcdir}/sanitizers-cmake"
+ git config submodule.lib/libappimage.url "${srcdir}/libappimage"
+ git submodule update
+
+ cd "$srcdir/$_pkgname/lib/AppImageUpdate/lib/libappimage"
+ git submodule init
+ git config submodule.lib/gtest.url "${srcdir}/googletest"
+ git submodule init
- git submodule update --init --recursive
+ cd "$srcdir/$_pkgname/lib/AppImageUpdate/lib/zsync2"
+ git submodule init
+
+ git config submodule.lib/cpr.url "${srcdir}/cpr"
+ git config submodule.lib/args.url "${srcdir}/args"
+ git config submodule.lib/gtest.url "${srcdir}/googletest"
+ git submodule update
+
+ cd "${srcdir}/$_pkgname/lib/libappimage"
+ git submodule init
+ git config submodule.lib/gtest.url "${srcdir}/googletest"
+ git submodule update
}
build() {
cd "$srcdir/$_pkgname"
- cmake . -DCMAKE_INSTALL_PREFIX:PATH=/usr/ -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_BUILD_TYPE=Release
-
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DUSE_SYSTEM_GTEST=ON \
+ -DUSE_SYSTEM_XZ=ON \
+ -DUSE_SYSTEM_LIBARCHIVE=ON \
+ -DBUILD_TESTING=OFF
make
}
package() {
cd "$srcdir/$_pkgname"
-
- # must re-run CMake in order to populate the list of library files to bundle
- # see 2175cfb for more information
- cmake .
-
make DESTDIR="$pkgdir" install
-
- # install license files
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- cd "$srcdir"
-
- # Install pacman hook
- install -Dm644 -t "$pkgdir"/usr/share/libalpm/hooks *.hook
+ install -Dm644 ../appimage-binfmt-remove.hook "$pkgdir"/usr/share/libalpm/hooks/appimage-binfmt-remove.hook
}