summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-17 19:06:48 +0800
committerzxp198210052023-10-17 19:06:48 +0800
commit41dc91d3443d19715dde84552e8913852edc7a46 (patch)
tree5180f3c5e206f13cc15b1e08fd3f4f20d388bd34
downloadaur-41dc91d3443d19715dde84552e8913852edc7a46.tar.gz
update to 5.1.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD23
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42e6aee5701b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = appimagepool-bin
+ pkgdesc = A simple, modern AppImageHub Client, powered by flutter.
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = https://www.pling.com/p/1547076/
+ arch = x86_64
+ license = GPL3
+ depends = gtk3
+ depends = cairo
+ depends = hicolor-icon-theme
+ depends = gdk-pixbuf2
+ depends = glibc
+ depends = libepoxy
+ depends = glib2
+ depends = gcc-libs
+ depends = harfbuzz
+ depends = at-spi2-core
+ depends = pango
+ provides = appimagepool=5.1.0
+ conflicts = appimagepool
+ source = appimagepool-5.1.0.tar.gz::https://github.com/prateekmedia/appimagepool/releases/download/5.1.0/appimagepool-5.1.0-x86_64.tar.gz
+ sha256sums = 265d503d064f92334a5c7f4a90988931dee9451f4831c3751b49eeea7a016769
+
+pkgname = appimagepool-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dabcf4f491dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=appimagepool-bin
+pkgver=5.1.0
+pkgrel=1
+pkgdesc="A simple, modern AppImageHub Client, powered by flutter."
+arch=('x86_64')
+url="https://www.pling.com/p/1547076/"
+_githuburl="https://github.com/prateekmedia/appimagepool"
+license=('GPL3')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
+depends=('gtk3' 'cairo' 'hicolor-icon-theme' 'gdk-pixbuf2' 'glibc' 'libepoxy' 'glib2' 'gcc-libs' 'harfbuzz' 'at-spi2-core' 'pango')
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-${CARCH}.tar.gz")
+sha256sums=('265d503d064f92334a5c7f4a90988931dee9451f4831c3751b49eeea7a016769')
+package() {
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ cp -r "${srcdir}/usr/bin/"* "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/128x128/apps/${pkgname%-bin}.svg" \
+ -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/usr/share/metainfo/${pkgname%-bin}.appdata.xml" -t "${pkgdir}/usr/share/metainfo"
+} \ No newline at end of file