summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-04 18:10:21 +1300
committercaltlgin2020-10-04 18:10:21 +1300
commit082209c50a36d4b32252c351939d24797395d2f5 (patch)
treed726c155381366cf19692f681ea44b19e7e0a964
parentd9ed2018905c87ed9728a08c215a141e2956e2e0 (diff)
downloadaur-082209c50a36d4b32252c351939d24797395d2f5.tar.gz
Utilize CARCH for downloaded source file names
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b69b225522a..f2b7b5b3baf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,11 +14,11 @@ pkgbase = appimagetool-bin
source = appimagetool-12-LICENSE::https://github.com/AppImage/AppImageKit/raw/12/LICENSE
sha256sums = e7396f995fed233e08063a5bec8f26c343d7f1038f0fca80c3cad26d74090255
sha256sums = b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94
- source_x86_64 = appimagetool-12.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-x86_64.AppImage
+ source_x86_64 = appimagetool-12-x86_64.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-x86_64.AppImage
sha256sums_x86_64 = d918b4df547b388ef253f3c9e7f6529ca81a885395c31f619d9aaf7030499a13
- source_armv7h = appimagetool-12.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-armhf.AppImage
+ source_armv7h = appimagetool-12-armv7.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-armhf.AppImage
sha256sums_armv7h = 8bca91ae4dac9a6505a4939f29ce5c75b74a8c8e80d56f738b17863fbd6d2770
- source_aarch64 = appimagetool-12.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-aarch64.AppImage
+ source_aarch64 = appimagetool-12-aarch64.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-aarch64.AppImage
sha256sums_aarch64 = c9d058310a4e04b9fbbd81340fff2b5fb44943a630b31881e321719f271bd41a
pkgname = appimagetool-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8a6ca8b7c814..574e7216e52d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,9 @@ noextract=("${_pkgname}")
source=("${_pkgname}-${pkgver}-README.md::${url}/raw/${pkgver}/README.md"
"${_pkgname}-${pkgver}-LICENSE::${url}/raw/${pkgver}/LICENSE")
-source_x86_64=("${_pkgname}-${pkgver}.appimage::${url}/releases/download/${pkgver}/${_pkgname}-x86_64.AppImage")
-source_armv7h=("${_pkgname}-${pkgver}.appimage::${url}/releases/download/${pkgver}/${_pkgname}-armhf.AppImage")
-source_aarch64=("${_pkgname}-${pkgver}.appimage::${url}/releases/download/${pkgver}/${_pkgname}-aarch64.AppImage")
+source_x86_64=("${_pkgname}-${pkgver}-x86_64.appimage::${url}/releases/download/${pkgver}/${_pkgname}-x86_64.AppImage")
+source_armv7h=("${_pkgname}-${pkgver}-armv7.appimage::${url}/releases/download/${pkgver}/${_pkgname}-armhf.AppImage")
+source_aarch64=("${_pkgname}-${pkgver}-aarch64.appimage::${url}/releases/download/${pkgver}/${_pkgname}-aarch64.AppImage")
sha256sums=('e7396f995fed233e08063a5bec8f26c343d7f1038f0fca80c3cad26d74090255'
'b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94')
@@ -24,9 +24,9 @@ sha256sums_x86_64=('d918b4df547b388ef253f3c9e7f6529ca81a885395c31f619d9aaf703049
sha256sums_armv7h=('8bca91ae4dac9a6505a4939f29ce5c75b74a8c8e80d56f738b17863fbd6d2770')
sha256sums_aarch64=('c9d058310a4e04b9fbbd81340fff2b5fb44943a630b31881e321719f271bd41a')
-build() {
- chmod a+x "${_pkgname}-${pkgver}.appimage"
- ./"${_pkgname}-${pkgver}.appimage" --appimage-extract
+prepare() {
+ chmod a+x "${_pkgname}-${pkgver}-${CARCH}.appimage"
+ ./"${_pkgname}-${pkgver}-${CARCH}.appimage" --appimage-extract
}
package(){