summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-07 17:07:05 +1200
committercaltlgin2020-09-07 17:07:05 +1200
commitae71380951b481c4a949188c556476eaadb16a79 (patch)
tree1bced3d0d02ca74d66b76cd07177002ed1db8eb3
parent59a771f9b002d3f10be4c47dcef30801a055ac5a (diff)
downloadaur-ae71380951b481c4a949188c556476eaadb16a79.tar.gz
Clean PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c446a613d61..d202ca49c362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,11 +10,11 @@ pkgbase = appimagetool-bin
provides = appimagetool
noextract = appimagetool
source = appimagetool-12.appimage::https://github.com/AppImage/AppImageKit/releases/download/12/appimagetool-x86_64.appimage
- source = appimagetool-12-README.md::https://raw.githubusercontent.com/AppImage/AppImageKit/master/README.md
- source = appimagetool-12-LICENSE::https://raw.githubusercontent.com/AppImage/AppImageKit/master/LICENSE
+ source = appimagetool-12-README.md::https://github.com/AppImage/AppImageKit/raw/12/README.md
+ source = appimagetool-12-LICENSE::https://github.com/AppImage/AppImageKit/raw/12/LICENSE
sha256sums = d918b4df547b388ef253f3c9e7f6529ca81a885395c31f619d9aaf7030499a13
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = e7396f995fed233e08063a5bec8f26c343d7f1038f0fca80c3cad26d74090255
+ sha256sums = b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94
pkgname = appimagetool-bin
diff --git a/PKGBUILD b/PKGBUILD
index d370da96b253..eb890ee47001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname=appimagetool
-pkgname=${_pkgname}-bin
+_pkgname='appimagetool'
+pkgname="${_pkgname}-bin"
pkgver=12
pkgrel=1
pkgdesc='Package desktop applications as AppImages'
arch=('x86_64')
url='https://github.com/AppImage/AppImageKit'
-_rawurl="https://raw.githubusercontent.com/${url##*github.com/}"
license=('MIT')
depends=('libappimage')
optdepends=('zsync: binary delta updates')
provides=("${_pkgname}")
noextract=("${_pkgname}")
source=("${_pkgname}-${pkgver}.appimage::${url}/releases/download/${pkgver}/${_pkgname}-x86_64.appimage"
- "${_pkgname}-${pkgver}-README.md::${_rawurl}/master/README.md"
- "${_pkgname}-${pkgver}-LICENSE::${_rawurl}/master/LICENSE")
+ "${_pkgname}-${pkgver}-README.md::${url}/raw/${pkgver}/README.md"
+ "${_pkgname}-${pkgver}-LICENSE::${url}/raw/${pkgver}/LICENSE")
sha256sums=('d918b4df547b388ef253f3c9e7f6529ca81a885395c31f619d9aaf7030499a13'
- 'SKIP'
- 'SKIP')
+ 'e7396f995fed233e08063a5bec8f26c343d7f1038f0fca80c3cad26d74090255'
+ 'b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94')
build() {
chmod a+x "${_pkgname}-${pkgver}.appimage"