summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-28 16:30:12 +0800
committerzxp198210052023-09-28 16:30:12 +0800
commit1c2688d1052038c8bb350f1369dd338e4b74a12c (patch)
treea85ce2b01a458aa851cbfcd70183ebcff6794d6e
parent14317b64fa5b9ac8064af2fe9f1a8579598abbec (diff)
downloadaur-1c2688d1052038c8bb350f1369dd338e4b74a12c.tar.gz
update to 2.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f94870e1632d..10e2ed775052 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apple-music-bin
pkgdesc = An Electron app that provides a native Apple Music experience for Linux & Windows.
- pkgver = 0.1.4
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/Alex313031/apple-music-desktop
arch = x86_64
@@ -29,10 +29,10 @@ pkgbase = apple-music-bin
depends = glib2
depends = dbus
depends = libxcb
- provides = apple-music=0.1.4
+ provides = apple-music=2.0.1
conflicts = apple-music
options = !strip
- source = apple-music-0.1.4.deb::https://github.com/Alex313031/apple-music-desktop/releases/download/0.1.4/apple-music_0.1.4_amd64.deb
- sha256sums = 8e4c6ad52099566788bbd01cc792d1ca91e715353e4181f846438dd38a9c98a4
+ source = apple-music-2.0.1.deb::https://github.com/Alex313031/apple-music-desktop/releases/download/2.0.1/apple-music_2.0.1_amd64.deb
+ sha256sums = a5d2e23ee9e084c646f8a4a5a4c86259586de5d2ecc8ea12c9a12fb159bd6f4e
pkgname = apple-music-bin
diff --git a/PKGBUILD b/PKGBUILD
index bdc16dbd70e1..ca22180c7041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=apple-music-bin
_pkgname="Apple Music"
-pkgver=0.1.4
+pkgver=2.0.1
pkgrel=1
pkgdesc="An Electron app that provides a native Apple Music experience for Linux & Windows."
arch=('x86_64')
@@ -13,7 +13,7 @@ depends=('libxrandr' 'libxfixes' 'libxkbcommon' 'nspr' 'libx11' 'nss' 'libcups'
'libxcomposite' 'gcc-libs' 'hicolor-icon-theme' 'libxdamage' 'gtk3' 'glibc' 'at-spi2-core' 'libdrm' 'glib2' 'dbus' 'libxcb')
options=('!strip')
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
-sha256sums=('8e4c6ad52099566788bbd01cc792d1ca91e715353e4181f846438dd38a9c98a4')
+sha256sums=('a5d2e23ee9e084c646f8a4a5a4c86259586de5d2ecc8ea12c9a12fb159bd6f4e')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin} --no-sandbox|g" \