summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-15 12:42:05 +0800
committerzxp198210052023-07-15 12:42:05 +0800
commit1fef51843e46168061a34cee81a1e5311c86c540 (patch)
treed23a43a67255ad007795d6e22609b2d5a29ea2f6
parent571750f2f35c1c1bbcbb3fbffbcd47e0ef6ab6e2 (diff)
downloadaur-1fef51843e46168061a34cee81a1e5311c86c540.tar.gz
update to 3.1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--apple-music-electron.sh6
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e96a53aa462..237bf814dfa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apple-music-electron-bin
pkgdesc = A free, lightweight, open source alternative to iTunes and other Apple Music applications based on Electron 15
- pkgver = 3.0.2
+ pkgver = 3.1.1
pkgrel = 1
url = https://github.com/Alex313031/Apple-Music-Electron
arch = x86_64
@@ -18,11 +18,11 @@ pkgbase = apple-music-electron-bin
optdepends = otf-san-francisco: Use of SF Font for certain themes
provides = apple-music-electron
conflicts = apple-music-electron
- source = apple-music-electron-3.0.2.deb::https://github.com/Alex313031/Apple-Music-Electron/releases/download/v3.0.2/apple-music-electron_3.0.2_amd64.deb
- source = LICENSE::https://raw.githubusercontent.com/Alex313031/Apple-Music-Electron/master/LICENSE
+ source = apple-music-electron-3.1.1.deb::https://github.com/Alex313031/Apple-Music-Electron/releases/download/v3.1.1/apple-music_3.1.1_amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/Alex313031/Apple-Music-Electron/master/LICENSE.md
source = apple-music-electron.sh
- sha256sums = ebc08ea72c8e488a9f74539f45358c7f156078e7f5ca1e9c6e0d84e0a146d497
- sha256sums = cf7724c85c357c306a0a8489d987214070c547343f493532ffd4a847e6b8a186
- sha256sums = e0411c5d36829417b6a5931240854b34a6ef004b9034e5b9df82579763c5a30e
+ sha256sums = 7bf6157f871af6f3dee522ffbdb846c88689c2c87a542bdbe12898e1dfd280b8
+ sha256sums = 0fd63c3d94a7db5724728de22068188d45aa0c6be04c6e4c4c5983b5d46d5eee
+ sha256sums = 44dc6173c7bb88874ac68a31aaacc0bfb422a8fcd218d54cc124ebf36a5c5e72
pkgname = apple-music-electron-bin
diff --git a/PKGBUILD b/PKGBUILD
index 65bf45686210..412d4c3ed1f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
pkgname=apple-music-electron-bin
_pkgname=Apple-Music-Electron
-pkgver=3.0.2
+pkgver=3.1.1
pkgrel=1
pkgdesc="A free, lightweight, open source alternative to iTunes and other Apple Music applications based on Electron 15"
arch=('x86_64')
@@ -14,13 +14,12 @@ optdepends=('libnotify: Playback notifications'
'otf-san-francisco: Use of SF Font for certain themes')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
- "LICENSE::https://raw.githubusercontent.com/Alex313031/Apple-Music-Electron/master/LICENSE"
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-electron-bin}_${pkgver}_amd64.deb"
+ "LICENSE::https://raw.githubusercontent.com/Alex313031/Apple-Music-Electron/master/LICENSE.md"
"${pkgname%-bin}.sh")
-sha256sums=('ebc08ea72c8e488a9f74539f45358c7f156078e7f5ca1e9c6e0d84e0a146d497'
- 'cf7724c85c357c306a0a8489d987214070c547343f493532ffd4a847e6b8a186'
- 'e0411c5d36829417b6a5931240854b34a6ef004b9034e5b9df82579763c5a30e')
-
+sha256sums=('7bf6157f871af6f3dee522ffbdb846c88689c2c87a542bdbe12898e1dfd280b8'
+ '0fd63c3d94a7db5724728de22068188d45aa0c6be04c6e4c4c5983b5d46d5eee'
+ '44dc6173c7bb88874ac68a31aaacc0bfb422a8fcd218d54cc124ebf36a5c5e72')
package(){
bsdtar -xf "${srcdir}/data.tar.xz"
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
diff --git a/apple-music-electron.sh b/apple-music-electron.sh
index 43d8f973f08c..ab23efa30ba6 100644
--- a/apple-music-electron.sh
+++ b/apple-music-electron.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron15
+_ASAR="/opt/apple-music-electron/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron15 /opt/apple-music-electron/app.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron15 --no-sandbox /opt/apple-music-electron/app.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file