summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-10 11:54:18 +0800
committerzxp198210052023-08-10 11:54:18 +0800
commita41cf33f8d3ed5512cd79643b687e86719f1ab04 (patch)
tree46694523dd6b2de54db26542b5d26e0803f49f12
parent1fef51843e46168061a34cee81a1e5311c86c540 (diff)
downloadaur-a41cf33f8d3ed5512cd79643b687e86719f1ab04.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 237bf814dfa5..c94950493615 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = apple-music-electron-bin
pkgdesc = A free, lightweight, open source alternative to iTunes and other Apple Music applications based on Electron 15
pkgver = 3.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Alex313031/Apple-Music-Electron
arch = x86_64
license = MIT
+ depends = bash
depends = gcc-libs
depends = alsa-lib
depends = electron15
@@ -16,7 +17,7 @@ pkgbase = apple-music-electron-bin
depends = glibc
optdepends = libnotify: Playback notifications
optdepends = otf-san-francisco: Use of SF Font for certain themes
- provides = apple-music-electron
+ provides = apple-music-electron=3.1.1
conflicts = apple-music-electron
source = apple-music-electron-3.1.1.deb::https://github.com/Alex313031/Apple-Music-Electron/releases/download/v3.1.1/apple-music_3.1.1_amd64.deb
source = LICENSE::https://raw.githubusercontent.com/Alex313031/Apple-Music-Electron/master/LICENSE.md
diff --git a/PKGBUILD b/PKGBUILD
index 412d4c3ed1f4..05b2fe5b2083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Core_UK <mail.coreuk@gmail.com>
# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
pkgname=apple-music-electron-bin
-_pkgname=Apple-Music-Electron
+_pkgname="Apple Music"
pkgver=3.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A free, lightweight, open source alternative to iTunes and other Apple Music applications based on Electron 15"
arch=('x86_64')
url="https://github.com/Alex313031/Apple-Music-Electron"
license=("MIT")
-depends=('gcc-libs' 'alsa-lib' 'electron15' 'portaudio' 'hicolor-icon-theme' 'java-runtime' 'lib32-glibc' 'lib32-alsa-lib' 'glibc')
+depends=('bash' 'gcc-libs' 'alsa-lib' 'electron15' 'portaudio' 'hicolor-icon-theme' 'java-runtime' 'lib32-glibc' 'lib32-alsa-lib' 'glibc')
optdepends=('libnotify: Playback notifications'
'otf-san-francisco: Use of SF Font for certain themes')
conflicts=("${pkgname%-bin}")
-provides=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-electron-bin}_${pkgver}_amd64.deb"
"LICENSE::https://raw.githubusercontent.com/Alex313031/Apple-Music-Electron/master/LICENSE.md"
"${pkgname%-bin}.sh")
@@ -23,8 +23,8 @@ sha256sums=('7bf6157f871af6f3dee522ffbdb846c88689c2c87a542bdbe12898e1dfd280b8'
package(){
bsdtar -xf "${srcdir}/data.tar.xz"
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/opt/Apple Music/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
- sed "s|\"/opt/Apple Music/${pkgname%-bin}\" %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ cp -r "${srcdir}/opt/${_pkgname}/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
cp -r "${srcdir}/usr/share/icons" "${pkgdir}/usr/share"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"