summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-07-17 08:15:09 -0400
committerJames An2015-07-17 08:15:09 -0400
commit76514cce1f7dedb9c76557f8a1beb3cd0d9186db (patch)
treefb18e072ce337d47452dfc5cec59fc89e6885b42
downloadaur-76514cce1f7dedb9c76557f8a1beb3cd0d9186db.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD33
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..289a42a4df03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = apple_set_os
+ pkgdesc = Tiny EFI program for unlocking the Intel integrated graphics device on the Macbook Pro 11,3
+ pkgver = v0
+ pkgrel = 1
+ url = https://github.com/0xbb/apple_set_os.efi
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = gnu-efi-libs
+ optdepends = efibootmgr: manage UEFI boot entries
+ optdepends = grub: boot loader capable of UEFI chainloading
+ optdepends = gummiboot: boot loader capable of UEFI chainloading
+ optdepends = refind-efi: boot loader capable of UEFI chainloading
+ optdepends = systemd: has boot loader capable of UEFI chainloading
+ source = apple_set_os::git+https://github.com/0xbb/apple_set_os.efi.git
+ md5sums = SKIP
+
+pkgname = apple_set_os
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b16646938612
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=apple_set_os
+pkgver=v0
+pkgrel=1
+pkgdesc='Tiny EFI program for unlocking the Intel integrated graphics device on the Macbook Pro 11,3'
+arch=('i686' 'x86_64')
+url="https://github.com/0xbb/$pkgname.efi"
+license=('MIT')
+makedepends=('git' 'gnu-efi-libs')
+optdepends=(
+ 'efibootmgr: manage UEFI boot entries'
+ 'grub: boot loader capable of UEFI chainloading'
+ 'gummiboot: boot loader capable of UEFI chainloading'
+ 'refind-efi: boot loader capable of UEFI chainloading'
+ 'systemd: has boot loader capable of UEFI chainloading'
+)
+source=(
+ "$pkgname"::"git+https://github.com/0xbb/$pkgname.efi.git"
+)
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ install -Dm644 "$pkgname.efi" "$pkgdir/boot/EFI/tools/$pkgname.efi"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+}