summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-02-20 23:29:14 -0500
committerJames An2018-02-20 23:29:14 -0500
commit9a7dff8d2a38c601b22f42493434532eede22dd2 (patch)
tree4fddd891a54e87969dca845fa92946302e4e0e91
parent2a17f41c1abe2d2c3b9a7f4081c83f4f8340b8dc (diff)
downloadaur-9a7dff8d2a38c601b22f42493434532eede22dd2.tar.gz
Fixed pkgver() to remove leading 'v' in version string and updated pkgver accordingly.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e90c1fcbbab6..916b8bfc04d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apple_set_os
pkgdesc = Tiny EFI program for unlocking the Intel integrated graphics device on the Macbook Pro 11,3
- pkgver = v1.r6.g7b6fa20
+ pkgver = 1.r6.g7b6fa20
pkgrel = 1
url = https://github.com/0xbb/apple_set_os.efi
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 20d1522ceccf..bc90acf690f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: James An <james@jamesan.ca>
pkgname=apple_set_os
-pkgver=v1.r6.g7b6fa20
+pkgver=1.r6.g7b6fa20
pkgrel=1
pkgdesc='Tiny EFI program for unlocking the Intel integrated graphics device on the Macbook Pro 11,3'
arch=('i686' 'x86_64')
@@ -24,7 +24,7 @@ pkgver() {
cd "$pkgname"
(
set -o pipefail
- git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ git describe --long --tag | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}