summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-05-23 16:45:16 +0200
committerbartus2018-05-23 16:45:16 +0200
commit545c8a59ba2a0e3d5b75c08213a852bf87a54b8a (patch)
tree113b83ca41b1d5c2572a8ef28b7ba3c7dd2dbb32
parent2ee69250dc03bc4340b3c34e64b2d3a3de7d4591 (diff)
downloadaur-545c8a59ba2a0e3d5b75c08213a852bf87a54b8a.tar.gz
fix gcc8 complains about private delete constructor
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--gcc8.patch10
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a1c6fa92ff7..99d4c4fe5cc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = appleseed
pkgdesc = physically-based global illumination rendering engine primarily designed for animation and visual effects.
pkgver = 1.9.0
- pkgrel = 1
+ pkgrel = 2
url = http://appleseedhq.net
arch = x86_64
license = MIT
@@ -19,7 +19,9 @@ pkgbase = appleseed
provides = appleseed
conflicts = appleseed-git
source = https://github.com/appleseedhq/appleseed/archive/1.9.0-beta.tar.gz
+ source = gcc8.patch
md5sums = 2843aaf4f4b69088ac6466808b329b27
+ md5sums = 6e6b997cbfe06e0d74cdc3f74de12324
pkgname = appleseed
diff --git a/PKGBUILD b/PKGBUILD
index 76c055561f08..80e5ffc02408 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=appleseed
-pkgrel=1
+pkgrel=2
pkgver=1.9.0
_pkgver=${pkgver}-beta
pkgdesc="physically-based global illumination rendering engine primarily designed for animation and visual effects. "
@@ -13,9 +13,10 @@ depends=(python2 qt4 'seexpr>=2.11' boost openexr opencolorio openimageio opensh
makedepends=(cmake)
options=()
source=("https://github.com/${pkgname}hq/${pkgname}/archive/${_pkgver}.tar.gz"
+ gcc8.patch
)
md5sums=('2843aaf4f4b69088ac6466808b329b27'
- )
+ '6e6b997cbfe06e0d74cdc3f74de12324')
CMAKE_FLAGS="-DUSE_EXTERNAL_EXR=ON \
-DUSE_EXTERNAL_OCIO=ON \
@@ -42,6 +43,7 @@ prepare() {
grep -q avx /proc/cpuinfo && CMAKE_FLAGS="${CMAKE_FLAGS} -DUSE_AVX=ON"
grep -q avx2 /proc/cpuinfo && CMAKE_FLAGS="${CMAKE_FLAGS} -DUSE_AVX2=ON"
grep -q sse4_2 /proc/cpuinfo && CMAKE_FLAGS="${CMAKE_FLAGS} -DUSE_SSE42=ON"
+ patch -Np1 -i ../gcc8.patch
}
build() {
cd ${pkgname}-${_pkgver}
diff --git a/gcc8.patch b/gcc8.patch
new file mode 100644
index 000000000000..2065b8c6f106
--- /dev/null
+++ b/gcc8.patch
@@ -0,0 +1,10 @@
+--- orig/appleseed-1.9.0-beta/src/appleseed/renderer/kernel/texturing/oiiotexturesystem.h 2018-05-01 00:27:50.000000000 +0200
++++ appleseed-1.9.0-beta/src/appleseed/renderer/kernel/texturing/oiiotexturesystem.h 2018-05-22 21:24:28.824974453 +0200
+@@ -45,6 +45,7 @@
+
+ private:
+ ~OIIOTextureSystem() override;
++ void operator delete (void*) {}
+ };
+
+ class OIIOTextureSystemFactory