summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtFox32022-01-30 14:21:32 +0100
committerArtFox32022-01-30 14:21:32 +0100
commit0a0ec0904c1ddbe11bf6c765397472bd3be01d25 (patch)
treee721c3ce88395c22cc69920cdc486a1e561b743f
downloadaur-0a0ec0904c1ddbe11bf6c765397472bd3be01d25.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2aa15a219e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = applet-window-appmenu-git
+ pkgdesc = This is a Plasma 5 applet that shows the current window appmenu in your panels. This plasmoid is coming from Latte land but it can also support Plasma panels.
+ pkgver = v0.7.1.r2.ga673b19
+ pkgrel = 1
+ url = https://github.com/psifidotos/applet-window-appmenu.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = plasma-framework
+ depends = gettext
+ depends = kdecoration
+ source = applet-window-appmenu-git::git+https://github.com/psifidotos/applet-window-appmenu.git
+ md5sums = SKIP
+
+pkgname = applet-window-appmenu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed7bf0483fd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: ArtFox3 <artfox3@gmail.com>
+pkgname="applet-window-appmenu-git"
+pkgver=v0.7.1.r2.ga673b19
+pkgrel=1
+epoch=
+pkgdesc="This is a Plasma 5 applet that shows the current window appmenu in your panels. This plasmoid is coming from Latte land but it can also support Plasma panels."
+arch=('i686' 'x86_64')
+url="https://github.com/psifidotos/applet-window-appmenu.git"
+license=('GPL')
+groups=()
+makedepends=(
+ 'gcc' 'git' 'extra-cmake-modules'
+)
+depends=(
+ 'plasma-framework' 'gettext' 'kdecoration'
+)
+source=(
+ "$pkgname::git+$url"
+)
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$pkgname"
+ if ! [ -a build ] ; then
+ mkdir build
+ fi
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .. -Wnodev
+ make -j$(nproc)
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}