summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-05-18 17:25:40 +0200
committerFrederic Bezies2021-05-18 17:25:40 +0200
commit934c36a56042f52eac5aa953fe5894579c865dbd (patch)
tree74f12214d2b835b4897d396e63320e701476fe81
downloadaur-934c36a56042f52eac5aa953fe5894579c865dbd.tar.gz
initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD70
-rw-r--r--apple-logo.svgbin0 -> 29891 bytes
-rw-r--r--applewin-git.install8
-rw-r--r--applewin-qt.desktop9
-rw-r--r--applewin-sdl2.desktop9
6 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd6d15d2d8f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = applewin-git
+ pkgdesc = AppleWin Linux port by Audetto - GIT version
+ pkgver = v1.25.0.4.r1877.g54403f74
+ pkgrel = 1
+ url = https://github.com/audetto/AppleWin.git
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = boost-libs
+ depends = minizip
+ depends = libslirp
+ depends = sdl2_image
+ depends = qt5-gamepad
+ depends = qt5-multimedia
+ depends = libyaml
+ source = git+https://github.com/audetto/AppleWin.git
+ source = git+https://github.com/Dax89/QHexView.git#commit=54301e8
+ source = git+https://github.com/ocornut/imgui.git#commit=cbcd891
+ source = git+https://github.com/ocornut/imgui_club.git#commit=02e679b
+ source = applewin-sdl2.desktop
+ source = applewin-qt.desktop
+ source = apple-logo.svg
+ source = applewin-git.install
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 0c12ec3a65b8fb832b5931e443686c01e64b1c56882fd564d04b467ba6cb8f1a
+ sha256sums = a1f2f65e1d381436a357455c96ee0fd586021847ba206e595ca416df91085157
+ sha256sums = e3bbf57d2ad105c6211b0853fbb88f1c20d874d0a34b6ae263e2cf8c74e1568d
+ sha256sums = dcd3c07931963c23dd96440ba08d7da61491498977f39541947a37a3f6261ac9
+
+pkgname = applewin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24686f682ed3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+
+_pkgname=AppleWin
+_name=applewin
+pkgname="${_name}-git"
+pkgver=v1.25.0.4.r1877.g54403f74
+pkgrel=1
+pkgdesc="AppleWin Linux port by Audetto - GIT version"
+arch=('x86_64')
+url="https://github.com/audetto/AppleWin.git"
+license=('GPL2')
+depends=('boost-libs' 'minizip' 'libslirp' 'sdl2_image' 'qt5-gamepad' 'qt5-multimedia' 'libyaml')
+makedepends=('git' 'cmake' 'boost')
+source=("git+https://github.com/audetto/AppleWin.git"
+ "git+https://github.com/Dax89/QHexView.git#commit=54301e8"
+ "git+https://github.com/ocornut/imgui.git#commit=cbcd891"
+ "git+https://github.com/ocornut/imgui_club.git#commit=02e679b"
+ applewin-sdl2.desktop
+ applewin-qt.desktop
+ apple-logo.svg
+ applewin-git.install)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '0c12ec3a65b8fb832b5931e443686c01e64b1c56882fd564d04b467ba6cb8f1a'
+ 'a1f2f65e1d381436a357455c96ee0fd586021847ba206e595ca416df91085157'
+ 'e3bbf57d2ad105c6211b0853fbb88f1c20d874d0a34b6ae263e2cf8c74e1568d'
+ 'dcd3c07931963c23dd96440ba08d7da61491498977f39541947a37a3f6261ac9')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+
+cd ${srcdir}/${_pkgname}
+#
+# Moving 3rd party repositories
+# Kinda dirty, but I cannot get git submodules to work :(
+#
+# This is a work in progress. Any help appreciated for making everything
+# work with git submodule "magic" :)
+#
+cp -fra ${srcdir}/QHexView/* ${srcdir}/${_pkgname}/source/frontends/qt/QHexView/
+cp -fra ${srcdir}/imgui/* ${srcdir}/${_pkgname}/source/frontends/sdl/imgui/imgui/
+cp -fra ${srcdir}/imgui_club/* ${srcdir}/${_pkgname}/source/frontends/sdl/imgui/imgui_club/
+}
+
+build() {
+ cd $srcdir/${_pkgname}
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}
+ cd build
+ make DESTDIR="$pkgdir/" install
+ mkdir $pkgdir/usr/share/applications/
+ cp $srcdir/*.desktop $pkgdir/usr/share/applications/
+ mkdir $pkgdir/usr/share/applewin/common/
+ cp $srcdir/apple-logo.svg $pkgdir/usr/share/applewin/common/
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/apple-logo.svg b/apple-logo.svg
new file mode 100644
index 000000000000..77a610917828
--- /dev/null
+++ b/apple-logo.svg
Binary files differ
diff --git a/applewin-git.install b/applewin-git.install
new file mode 100644
index 000000000000..4fa11d7d8bc6
--- /dev/null
+++ b/applewin-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat <<EOF
+If you want to use uthernet, you must enter in a command line:
+sudo setcap cap_net_raw=ep ./sa2
+
+"Best" version is SDL2 one. QT version is slower.
+
+EOF
diff --git a/applewin-qt.desktop b/applewin-qt.desktop
new file mode 100644
index 000000000000..2e5ed240162d
--- /dev/null
+++ b/applewin-qt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=AppleWin - QT
+Comment=
+Exec=qapple
+Icon=/usr/share/applewin/common/apple-logo.svg
+Terminal=False
+Categories=Game;Emulator
diff --git a/applewin-sdl2.desktop b/applewin-sdl2.desktop
new file mode 100644
index 000000000000..0627f5566300
--- /dev/null
+++ b/applewin-sdl2.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=AppleWin - SDL2
+Comment=
+Exec=sa2 --imgui
+Icon=/usr/share/applewin/common/apple-logo.svg
+Terminal=False
+Categories=Game;Emulator