summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2023-02-04 17:03:44 +0100
committerAlphaJack2023-02-04 17:03:44 +0100
commita05bc8685d083398aa7a15ee08493fd8e92b8183 (patch)
treec291f393da8ec62760ad758db9d93d4c23080a79
downloadaur-a05bc8685d083398aa7a15ee08493fd8e92b8183.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57f99f6f5ef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = apprise
+ pkgdesc = Push Notifications that work with just about every platform
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/caronc/apprise
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-certifi
+ depends = python-click
+ depends = python-dataclasses
+ depends = python-markdown
+ depends = python-requests
+ depends = python-requests-oauthlib
+ depends = python-yaml
+ provides = apprise
+ conflicts = python-apprise
+ options = !strip
+ source = https://github.com/caronc/apprise/releases/download/v1.2.1/apprise-1.2.1.tar.gz
+ sha256sums = 67e0c227eecee260000980dbbf8ba1e5eebdbe494f4730808297c9e645c03579
+
+pkgname = apprise
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..945f6d61fccd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="apprise"
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Push Notifications that work with just about every platform"
+url="https://github.com/caronc/apprise"
+license=("MIT")
+arch=("any")
+provides=("apprise")
+conflicts=("python-apprise")
+depends=(
+ "python-certifi"
+ "python-click"
+ "python-dataclasses"
+ "python-markdown"
+ "python-requests"
+ "python-requests-oauthlib"
+ "python-yaml")
+makedepends=("python-build" "python-installer" "python-wheel")
+options=("!strip")
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('67e0c227eecee260000980dbbf8ba1e5eebdbe494f4730808297c9e645c03579')
+
+build(){
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}