summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirco Tischler2015-12-07 18:09:17 +0100
committerMirco Tischler2015-12-07 18:09:17 +0100
commit46c644fc6fbd2791dd7fd1a4ed864cb2230a355e (patch)
treed3b60cf758f26b3d9bf6dd0cb6b02da99d1ed71a
downloadaur-46c644fc6fbd2791dd7fd1a4ed864cb2230a355e.tar.gz
appstream-glib-git: builds with version 0.5.4-r5
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD45
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ca9dae86b8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Mon Dec 7 17:08:53 UTC 2015
+pkgbase = appstream-glib-git
+ pkgdesc = Provides GObjects and helper methods to make it easy to read and write AppStream metadata (git version)
+ pkgver = appstream.glib.0.5.4.r5.g0f0c7a9
+ pkgrel = 1
+ url = http://people.freedesktop.org/~hughsient/appstream-glib/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = git
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ depends = gtk3
+ depends = libyaml
+ depends = pacman
+ depends = gcab
+ provides = appdata-tools
+ provides = appstream-glib=appstream.glib.0.5.4.r5.g0f0c7a9
+ conflicts = appdata-tools
+ conflicts = appstream-glib
+ replaces = appdata-tools
+ source = git+https://github.com/hughsie/appstream-glib.git
+ md5sums = SKIP
+
+pkgname = appstream-glib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef41395b5494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer: Mirco Tischler <mt-ml@gmx.de>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_pkgname=appstream-glib
+pkgname=${_pkgname}-git
+pkgver=appstream.glib.0.5.4.r5.g0f0c7a9
+pkgrel=1
+pkgdesc="Provides GObjects and helper methods to make it easy to read and write AppStream metadata (git version)"
+arch=('i686' 'x86_64')
+url="http://people.freedesktop.org/~hughsient/appstream-glib/"
+license=('LGPL')
+depends=('gtk3' 'libyaml' 'pacman' 'gcab')
+makedepends=('intltool' 'git' 'gtk-doc' 'gobject-introspection')
+provides=('appdata-tools' "appstream-glib=${pkgver}")
+conflicts=('appdata-tools' 'appstream-glib')
+replaces=('appdata-tools')
+source=('git+https://github.com/hughsie/appstream-glib.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+
+ git describe --always| sed 's|^appstrea_glib_||;s|\([^-].\)-|\1-r|;s|[-_]|\.|g'
+}
+
+build() {
+ cd "$_pkgname"
+ ./autogen.sh --prefix=/usr --enable-alpm
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+check() {
+ cd "$_pkgname"
+ make -k check || :
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+}