summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Nixon2020-12-24 10:57:14 +0000
committerDan Nixon2020-12-24 11:01:50 +0000
commit90a32d9d9a06c919cc46eb1ed8a2f0c727a04d8e (patch)
tree5e1b4dfce12c682568ef3807f853be2b7d8e9b87
downloadaur-aprsgateway-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..845c1abb96d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aprsgateway-git
+ pkgdesc = A single point of access to the APRS network for other radio network gateway programs.
+ pkgver = r37.6bee1c1
+ pkgrel = 1
+ url = https://github.com/g4klx/APRSGateway
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = git
+ provides = aprsgateway
+ conflicts = aprsgateway
+ backup = etc/APRSGateway.ini
+ source = aprsgateway::git+https://github.com/g4klx/APRSGateway.git
+ md5sums = SKIP
+
+pkgname = aprsgateway-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6daa0f03a0a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dan Nixon <dan@dan-nixon.com>
+pkgname=aprsgateway-git
+pkgver=r37.6bee1c1
+pkgrel=1
+pkgdesc="A single point of access to the APRS network for other radio network gateway programs."
+arch=('x86_64' 'i686')
+url="https://github.com/g4klx/APRSGateway"
+license=('GPL2')
+depends=()
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('aprsgateway::git+https://github.com/g4klx/APRSGateway.git')
+md5sums=('SKIP')
+backup=('etc/APRSGateway.ini')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make all
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm 755 APRSGateway "${pkgdir}/usr/bin/APRSGateway"
+ install -Dm 600 APRSGateway.ini "${pkgdir}/etc/APRSGateway.ini"
+}