summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2016-08-27 11:38:57 -0400
committerMark Weiman2016-08-27 11:38:57 -0400
commitecc19769d2667d70eadee645085a4f38997a6cbc (patch)
tree3a873210d8fbe2230db7a1904aabf64bb150df92
parentbf602cd630724e56ef0cd9135a4d0e8282f82591 (diff)
downloadaur-ecc19769d2667d70eadee645085a4f38997a6cbc.tar.gz
downgrade to 1.2.14 and fix build
Signed-off-by: Mark Weiman <mark.weiman@markzz.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f54eb753c937..7da89a1655e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Aug 19 13:39:58 UTC 2016
+# Sat Aug 27 15:38:22 UTC 2016
pkgbase = apt
- pkgdesc = Command-line package manager used on Debian-based systems
- pkgver = 1.3~rc2
+ pkgdesc = commandline package manager
+ pkgver = 1.2.14
pkgrel = 1
url = http://packages.debian.org/sid/apt
arch = i686
@@ -20,8 +20,8 @@ pkgbase = apt
provides = libapt-pkg
provides = libapt-pkg-dev
provides = apt-utils
- source = http://ftp.debian.org/debian/pool/main/a/apt/apt_1.3~rc2.tar.xz
- sha256sums = 96e63bd2d04bce992b81bff2d4887c05d1888fc3f9e9c85749934446755aa869
+ source = https://github.com/Debian/apt/archive/1.2.14.tar.gz
+ sha256sums = 5809427f78a9e3081ff0afc0547a9917ea9115ce634f4479015f3a14b1eb527d
pkgname = apt
diff --git a/PKGBUILD b/PKGBUILD
index 28274ca364b5..8ed2bdfbab3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,24 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=apt
-pkgver=1.3~rc2
+pkgver=1.2.14
pkgrel=1
-pkgdesc="Command-line package manager used on Debian-based systems"
+pkgdesc="commandline package manager"
arch=('i686' 'x86_64')
url="http://packages.debian.org/sid/apt"
license=('GPL2')
depends=('gnupg' 'curl' 'xz')
makedepends=('dpkg' 'docbook-xsl' 'po4a' 'gtest' 'dash')
-checkdepends=()
-optdepends=()
provides=('libapt-inst' 'libapt-pkg' 'libapt-pkg-dev' "apt-utils")
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=(http://ftp.debian.org/debian/pool/main/a/$pkgname/${pkgname}_$pkgver.tar.xz)
-sha256sums=('96e63bd2d04bce992b81bff2d4887c05d1888fc3f9e9c85749934446755aa869')
+source=(https://github.com/Debian/apt/archive/1.2.14.tar.gz)
+sha256sums=('5809427f78a9e3081ff0afc0547a9917ea9115ce634f4479015f3a14b1eb527d')
build() {
cd "$srcdir/$pkgname-$pkgver"
# this only copies config.{guess,sub} and displays errors
automake --add-missing --no-force -W none 2> /dev/null || true
+ autoreconf --install || true
_stylesheet=`ls -d /usr/share/xml/docbook/xsl-stylesheets-* | xargs basename`
sed -i -e "s|stylesheet/nwalsh|$_stylesheet|" doc/manpage-style.xsl
# disable debiandoc, this saves us from sgml problems