summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolsTiCe d'Hiver2022-06-06 13:50:52 +0200
committersolsTiCe d'Hiver2022-06-06 13:52:48 +0200
commit199d4721426876cfb639cbd48208ddc6bede99d4 (patch)
tree1be48371a99c034ed3c971140578247c7b3fda8e
parenta788c71c94105628c81ab8f6ed4d90ec3623a2fe (diff)
downloadaur-199d4721426876cfb639cbd48208ddc6bede99d4.tar.gz
Add archlinuxarm mirror at will
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 686c4094c983..f4401a36d784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apt-cacher-ng
pkgdesc = A caching proxy specialized for package files
pkgver = 3.7.4
-pkgrel = 5
+pkgrel = 6
url = http://www.unix-ag.uni-kl.de/~bloch/acng/
install = apt-cacher-ng.install
arch = i686
@@ -22,10 +22,12 @@ optdepends = mailcap: to get correct Content-Type header on doc html served by a
backup = etc/apt-cacher-ng/acng.conf
backup = etc/apt-cacher-ng/security.conf
source = http://deb.debian.org/debian/pool/main/a/apt-cacher-ng/apt-cacher-ng_3.7.4.orig.tar.xz
+source = https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/core/pacman-mirrorlist/mirrorlist
source = acng.conf.patch
source = apt-cacher-ng.service.patch
source = apt-cacher-ng.tmpfile
sha256sums = 63140473a669c42f5e2219e38fa9d7c733f9047699dde52c3bd828e372929a5f
+sha256sums = 5d622ca30f7a47e6e9cd536720912e0ef0a1ee96d4a5f3fe7c119cb495aec76f
sha256sums = 695c074de35a75730e6b711960993f00f120634276349c8640db2ad883a5ad09
sha256sums = c89335ea833fc04ec2ce6598e3fdaf86aa8f2fa0892203eef4c0a5cb24d6c188
sha256sums = ead4e80771f88b42d922aff6c62da93ae9c9b001a071043e2092949f2337b459
diff --git a/.gitignore b/.gitignore
index 874021d6271f..00ad01b3a6b9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
*.pkg.tar*
pkg/
src/
+mirrorlist
diff --git a/PKGBUILD b/PKGBUILD
index 2a60af0b5fdf..2699a75daa8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=apt-cacher-ng
pkgver=3.7.4
-pkgrel=5
+pkgrel=6
pkgdesc="A caching proxy specialized for package files"
url="http://www.unix-ag.uni-kl.de/~bloch/acng/"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -19,23 +19,27 @@ depends=('zlib' 'bzip2' 'fuse' 'xz' 'openssl' 'libwrap' 'libevent' 'c-ares')
optdepends=('mailcap: to get correct Content-Type header on doc html served by apt-cacher-ng')
makedepends=('cmake')
source=("http://deb.debian.org/debian/pool/main/a/apt-cacher-ng/apt-cacher-ng_${pkgver}.orig.tar.xz"
+ 'https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/core/pacman-mirrorlist/mirrorlist'
'acng.conf.patch'
'apt-cacher-ng.service.patch'
'apt-cacher-ng.tmpfile'
)
backup=('etc/apt-cacher-ng/acng.conf' 'etc/apt-cacher-ng/security.conf')
+install=apt-cacher-ng.install
sha256sums=('63140473a669c42f5e2219e38fa9d7c733f9047699dde52c3bd828e372929a5f'
+ '5d622ca30f7a47e6e9cd536720912e0ef0a1ee96d4a5f3fe7c119cb495aec76f'
'695c074de35a75730e6b711960993f00f120634276349c8640db2ad883a5ad09'
'c89335ea833fc04ec2ce6598e3fdaf86aa8f2fa0892203eef4c0a5cb24d6c188'
'ead4e80771f88b42d922aff6c62da93ae9c9b001a071043e2092949f2337b459')
-install=apt-cacher-ng.install
-
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
# === uncomment the next line to update mirrors [w3m package is needed]; it will take some time ===
#make -f scripts/Makefile.release gendbs
+
+ # === uncomment next line to add archlinuxarm mirrors to archlx_mirrors file ===
+ #grep '^# Server' ${srcdir}/mirrorlist|sed -e 's/^# Server = //' -e 's/$arch\/$repo$//' >> conf/archlx_mirrors
}
build() {