summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolsTiCe d'Hiver2022-06-03 21:39:30 +0200
committersolsTiCe d'Hiver2022-06-03 21:41:00 +0200
commitec8b4d444e92fb3b90ca21813f719d2c4f4cefb2 (patch)
treeaba90c615eedf1fcb571c12882b6fe413fdf92ca
parent9542ce4b16e6c1871e9b2bfa5d65a40316ab25a5 (diff)
downloadaur-ec8b4d444e92fb3b90ca21813f719d2c4f4cefb2.tar.gz
Update to 3.7.4
-rw-r--r--.SRCINFO53
-rw-r--r--PKGBUILD22
-rw-r--r--acng.conf.patch20
3 files changed, 46 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3514493eebb1..82bbdbfaf4f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,30 @@
pkgbase = apt-cacher-ng
- pkgdesc = A caching proxy specialized for package files.
- pkgver = 3.6.4
- pkgrel = 1
- url = http://www.unix-ag.uni-kl.de/~bloch/acng/
- install = apt-cacher-ng.install
- arch = i686
- arch = x86_64
- arch = armv7h
- license = custom
- makedepends = cmake
- depends = zlib
- depends = bzip2
- depends = fuse
- depends = xz
- depends = openssl
- depends = libwrap
- depends = libevent
- backup = etc/apt-cacher-ng/acng.conf
- source = http://snapshot.debian.org/archive/debian-debug/20210604T083012Z/pool/main/a/apt-cacher-ng/apt-cacher-ng_3.6.4.orig.tar.xz
- source = acng.conf.patch
- source = apt-cacher-ng.service.patch
- source = apt-cacher-ng.tmpfile
- md5sums = 27e61ad5c085e6640749184e75d2f630
- md5sums = 615f24677e35a346990c9a040293bb9a
- md5sums = 814ce1d0820f1a42d6aab483a6961fc6
- md5sums = 29979b8064ff52aa24017b42c37e6bfb
+pkgdesc = A caching proxy specialized for package files.
+pkgver = 3.7.4
+pkgrel = 1
+url = http://www.unix-ag.uni-kl.de/~bloch/acng/
+install = apt-cacher-ng.install
+arch = i686
+arch = x86_64
+arch = armv7h
+arch = aarch64
+license = custom
+makedepends = cmake
+depends = zlib
+depends = bzip2
+depends = fuse
+depends = xz
+depends = openssl
+depends = libwrap
+depends = libevent
+backup = etc/apt-cacher-ng/acng.conf
+source = http://deb.debian.org/debian/pool/main/a/apt-cacher-ng/apt-cacher-ng_3.7.4.orig.tar.xz
+source = acng.conf.patch
+source = apt-cacher-ng.service.patch
+source = apt-cacher-ng.tmpfile
+sha256sums = 63140473a669c42f5e2219e38fa9d7c733f9047699dde52c3bd828e372929a5f
+sha256sums = 695c074de35a75730e6b711960993f00f120634276349c8640db2ad883a5ad09
+sha256sums = c89335ea833fc04ec2ce6598e3fdaf86aa8f2fa0892203eef4c0a5cb24d6c188
+sha256sums = ead4e80771f88b42d922aff6c62da93ae9c9b001a071043e2092949f2337b459
pkgname = apt-cacher-ng
diff --git a/PKGBUILD b/PKGBUILD
index 8b76ff647c4d..48e0e98e6281 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,29 +8,28 @@
# Contributor: Christian Schwarz <me et cschwarz punkt com>
pkgname=apt-cacher-ng
-pkgver=3.6.4
+pkgver=3.7.4
pkgrel=1
pkgdesc="A caching proxy specialized for package files."
url="http://www.unix-ag.uni-kl.de/~bloch/acng/"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('custom')
depends=('zlib' 'bzip2' 'fuse' 'xz' 'openssl' 'libwrap' 'libevent')
makedepends=('cmake')
-source=("http://snapshot.debian.org/archive/debian-debug/20210604T083012Z/pool/main/a/apt-cacher-ng/apt-cacher-ng_${pkgver}.orig.tar.xz"
+source=("http://deb.debian.org/debian/pool/main/a/apt-cacher-ng/apt-cacher-ng_${pkgver}.orig.tar.xz"
'acng.conf.patch'
'apt-cacher-ng.service.patch'
'apt-cacher-ng.tmpfile'
)
backup=('etc/apt-cacher-ng/acng.conf')
-md5sums=('27e61ad5c085e6640749184e75d2f630' # package
- '615f24677e35a346990c9a040293bb9a' # acng.conf.patch
- '814ce1d0820f1a42d6aab483a6961fc6' # apt-cacher-ng.service.patch
- '29979b8064ff52aa24017b42c37e6bfb') # apt-cacher-ng.tmpfile
+sha256sums=('63140473a669c42f5e2219e38fa9d7c733f9047699dde52c3bd828e372929a5f'
+ '695c074de35a75730e6b711960993f00f120634276349c8640db2ad883a5ad09'
+ 'c89335ea833fc04ec2ce6598e3fdaf86aa8f2fa0892203eef4c0a5cb24d6c188'
+ 'ead4e80771f88b42d922aff6c62da93ae9c9b001a071043e2092949f2337b459')
install=apt-cacher-ng.install
-
build() {
cd ${srcdir}/${pkgname}-${pkgver}
rm -rf builddir
@@ -39,7 +38,12 @@ build() {
cd builddir
- cmake $src -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DEXTRA_LIBS_ACNG=pthread || return 1
+ cmake $src -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DRUNDIR=/run \
+ -DACNG_CACHE_DIR=/var/cache/apt-cacher-ng \
+ -DACNG_LOG_DIR=/var/log/apt-cacher-ng \
+ -DEXTRA_LIBS_ACNG=pthread || return 1
make all || return 1
diff --git a/acng.conf.patch b/acng.conf.patch
index b96e0fe3dd87..294f864975f0 100644
--- a/acng.conf.patch
+++ b/acng.conf.patch
@@ -1,28 +1,20 @@
---- conf/acng.conf 2020-02-05 14:59:30.934092728 +0800
-+++ conf/acng.conf.arch 2020-02-05 15:03:00.233717419 +0800
-@@ -92,7 +92,7 @@
+--- conf/acng.conf 2022-06-03 20:12:04.247525890 +0200
++++ conf/acng.conf 2022-06-03 20:12:48.103341315 +0200
+@@ -95,7 +95,7 @@
#
# Default: /run/apt-cacher-ng/socket
#
-# SocketPath: /var/run/apt-cacher-ng/socket
+SocketPath: /run/apt-cacher-ng/socket
-
+
# If set to 1, makes log files be written to disk on every new line. Default
# is 0, buffers are flushed after the client disconnects. Technically,
-@@ -112,7 +112,7 @@
+@@ -115,7 +115,7 @@
# Store the pid of the daemon process in the specified text file.
# Default: disabled
#
-# PidFile: /var/run/apt-cacher-ng/pid
+PidFile: /run/apt-cacher-ng/pid
-
+
# Forbid outgoing connections and work without an internet connection or
# respond with 503 error where it's not possible.
-@@ -235,6 +235,7 @@
- # To see examples of the expected syntax, run: apt-cacher-ng -p debug=1
- #
- # PfilePatternEx:
-+PfilePattern = .(.d?deb|.db|.rpm|.drpm|.dsc|.tar(.gz|.bz2|.lzma|.xz|.zst)(.gpg)?|.diff(.gz|.bz2|.lzma|.zst|.xz)|.jigdo|.template|changelog|copyright|.udeb|.debdelta|.diff/..gz|(Devel)?ReleaseAnnouncement(\?.)?|[a-f0-9]+-(susedata|updateinfo|primary|deltainfo).xml.gz|fonts/(final/)?[a-z]+32.exe(\?download.)?|/dists/./installer-[^/]+/[0-9][^/]+/images/.)$
- # VfilePatternEx:
- # SPfilePatternEx:
- # SVfilePatternEx: