summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-11-24 19:33:19 +0100
committersL1pKn072021-11-24 19:33:19 +0100
commitc01f36c4d06f9c08b67ad3511c4aea4e0007a31c (patch)
tree1693547e358c17dad4163996015fdd1628176be0
downloadaur-c01f36c4d06f9c08b67ad3511c4aea4e0007a31c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3be02eb912f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = apt-file
+ pkgdesc = APT package searching utility
+ pkgver = 2021.4.0
+ pkgrel = 1
+ url = https://packages.debian.org
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = perl-aptpkg
+ backup = etc/apt/apt-file.conf
+ source = git+https://salsa.debian.org/apt-team/apt-file.git
+ sha256sums = SKIP
+
+pkgname = apt-file
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15208a2f6c17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=apt-file
+pkgver=2021.4.0
+pkgrel=1
+pkgdesc='APT package searching utility'
+url='https://packages.debian.org'
+arch=('any')
+license=('GPL')
+depends=('perl-aptpkg')
+makedepends=('git')
+source=('git+https://salsa.debian.org/apt-team/apt-file.git')
+sha256sums=('SKIP')
+backup=('etc/apt/apt-file.conf')
+
+build() {
+ pwd
+ cd apt-file
+ make
+}
+
+package() {
+ cd apt-file
+ install -Dm755 apt-file "${pkgdir}/usr/bin/apt-file"
+ install -Dm644 apt-file.1 "${pkgdir}/usr/share/man/man1/apt-file.1"
+ install -Dm644 examples-apt-conf/apt-file.conf "${pkgdir}/etc/apt/apt-file.conf"
+}