summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Jasek2019-04-15 18:45:49 -0400
committerTomas Jasek2019-04-15 18:45:49 -0400
commitf2daaa1d54bea098cf2b40b82a1aa799a7d3fa24 (patch)
tree0834642b9dbe071077a095f6e4a3b90d02e0bd35
parent18df34b66af0486296f576f928ed79337247dfa3 (diff)
downloadaur-aptana-studio.tar.gz
Fix installation issues
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5836e3fe8b84..b3e7c8ef4aba 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Nov 15 21:39:36 UTC 2018
+# Mon Apr 15 22:45:39 UTC 2019
pkgbase = aptana-studio
- pkgdesc = Aptana Studio 3.6.1 is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing.
+ pkgdesc = Aptana Studio is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing.
pkgver = 3.7.2.201807301111
- pkgrel = 1
+ pkgrel = 2
url = http://www.aptana.com/products/studio3/download.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 866583d49a5a..24869836aa42 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname="aptana-studio"
pkgver="3.7.2.201807301111"
-pkgrel=1
-pkgdesc="Aptana Studio 3.6.1 is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing. "
+pkgrel=2
+pkgdesc="Aptana Studio is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing. "
arch=('i686' 'x86_64')
url="http://www.aptana.com/products/studio3/download.html"
license=('GPL3')
@@ -30,7 +30,8 @@ noextract=()
build() {
cd $srcdir
- bsdtar -xf *.zip
+ mkdir -p Aptana_Studio_3
+ bsdtar -xf *.zip -C Aptana_Studio_3
mkdir -p $srcdir/usr/bin/
echo 'exec /usr/lib/aptana/AptanaStudio3' > $srcdir/usr/bin/aptana-studio
}
@@ -43,6 +44,7 @@ package() {
mv Aptana_Studio_3/* aptana
rm -rf Aptana_Studio_3
mkdir -p $pkgdir/usr/bin/
+ install -m775 $srcdir/AptanaStudio3 $pkgdir/usr/lib/aptana/AptanaStudio3
install -m775 $srcdir/usr/bin/aptana-studio $pkgdir/usr/bin/aptana-studio
install -Dm644 $srcdir/aptana-studio.desktop "${pkgdir}/usr/share/applications/aptana-studio.desktop"
}