summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph R. Prostko2016-04-30 09:45:11 -0400
committerJoseph R. Prostko2016-04-30 09:45:11 -0400
commitd0ef5827d3c94de75f3f3e850d49361d7daab063 (patch)
tree367baf51bfd4112667f2b6e038cbc9b4a9664dc5
downloadaur-d0ef5827d3c94de75f3f3e850d49361d7daab063.tar.gz
Add aptly 0.9.7 to the AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b04111343379
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Apr 30 13:43:59 UTC 2016
+pkgbase = aptly
+ pkgdesc = A Swiss Army knife for Debian repository management.
+ pkgver = 0.9.7
+ pkgrel = 1
+ url = https://www.aptly.info
+ arch = i686
+ arch = x86_64
+ license = MIT
+ options = !strip
+ source_i686 = https://bintray.com/artifact/download/smira/aptly/aptly_0.9.7_linux_386.tar.gz
+ sha256sums_i686 = 22b5ab49714d9c2ceaa31c1529cad2e2a968378de2e3c67d41ef5c53211472e1
+ source_x86_64 = https://bintray.com/artifact/download/smira/aptly/aptly_0.9.7_linux_amd64.tar.gz
+ sha256sums_x86_64 = ec877942783c7a24566c802120da51d4cecaf2c76d3151e1a4869da1ee0690f7
+
+pkgname = aptly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f131fc875714
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Joseph R. Prostko <joe dot prostko at gmail dot com>
+
+pkgname=aptly
+pkgver=0.9.7
+pkgrel=1
+pkgdesc="A Swiss Army knife for Debian repository management."
+url="https://www.aptly.info"
+license=('MIT')
+options=(!strip)
+arch=('i686' 'x86_64')
+source_i686=("https://bintray.com/artifact/download/smira/aptly/aptly_${pkgver}_linux_386.tar.gz")
+source_x86_64=("https://bintray.com/artifact/download/smira/aptly/aptly_${pkgver}_linux_amd64.tar.gz")
+sha256sums_i686=('22b5ab49714d9c2ceaa31c1529cad2e2a968378de2e3c67d41ef5c53211472e1')
+sha256sums_x86_64=('ec877942783c7a24566c802120da51d4cecaf2c76d3151e1a4869da1ee0690f7')
+
+package() {
+ # Test for current architecture
+ if test "$CARCH" == x86_64; then
+ _arch="amd64"; else
+ _arch="386"
+ fi
+
+ # Install the binary and the license file
+ cd ${pkgname}_${pkgver}_linux_${_arch}
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}