summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-03-07 12:33:36 +0900
committerhayao2020-03-07 12:33:36 +0900
commita9869e1d341a5dfe7ef5bfff3e048b5804f187ad (patch)
tree0814585eeddcfbc513366392f0723a4043716d68
downloadaur-a9869e1d341a5dfe7ef5bfff3e048b5804f187ad.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08d1c9209920
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aptpac
+ pkgdesc = a pacman wrapper with syntax from debian's apt
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/Hayao0819/aptpac
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ depends = sudo
+ conflicts = apt
+ conflicts = apt-git
+ conflicts = aptpac-git
+ source = https://github.com/Hayao0819/aptpac/archive/v2.0.0.zip
+ md5sums = SKIP
+
+pkgname = aptpac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3608c1f8fc45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintaoner: Yamada Hayao <development@fascode.net>
+# Maintainer: Abraham Levine <echo iue@trnspljc.890 | tr ietursnpl890jc acprlsurecomed>
+
+pkgname=aptpac
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="a pacman wrapper with syntax from debian's apt"
+arch=('i686' 'x86_64')
+url="https://github.com/Hayao0819/aptpac"
+license=('WTFPL')
+depends=('sudo')
+makedepends=('git')
+source=("${url}/archive/v${pkgver}.zip")
+md5sums=('SKIP')
+_gitname='aptpac'
+conflicts=('apt' 'apt-git' 'aptpac-git')
+
+
+package() {
+ cd "${_gitname}-${pkgver}" &&
+ install -m 755 -D aptpac "${pkgdir}/usr/bin/aptpac"
+ ln -s "${pkgdir}/usr/bin/aptpac" "${pkgdir}/usr/bin/apt"
+ ln -s "${pkgdir}/usr/bin/aptpac" "${pkgdir}/usr/bin/apt-get"
+}