summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-07-08 14:54:09 +0200
committerChristian Hesse2015-07-08 14:54:09 +0200
commit6bd73b42ab41659c5b87b319045976056d960b22 (patch)
tree0fbb5a818d7ab76869812c52e37ffab8cc4aa009
downloadaur-6bd73b42ab41659c5b87b319045976056d960b22.tar.gz
initial import of apulse 0.1.6-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
-rw-r--r--apulse.install13
-rw-r--r--asoundrc.sample15
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9363fc2ca5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = apulse
+ pkgdesc = PulseAudio emulation for ALSA
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/i-rinat/apulse
+ install = apulse.install
+ arch = i686
+ arch = x86_64
+ license = custom:MIT
+ makedepends = cmake
+ depends = alsa-lib
+ depends = glib2
+ source = apulse-0.1.6.tar.gz::https://github.com/i-rinat/apulse/archive/v0.1.6.tar.gz
+ source = asoundrc.sample
+ sha256sums = f9ffbf7aff96680beff3243758e5c1e0d4ac9043d4bd6cbfb219890b4b91c9f3
+ sha256sums = e851197ec9ebff528154210751cd6d5c426abfc2b1aa34343580407b1ea789a4
+
+pkgname = apulse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b53adb15a4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Christian Hesse <arch@eworm.de>
+# Contributor: speps <speps at aur dot archlinux dot org>
+
+pkgname=apulse
+pkgver=0.1.6
+pkgrel=1
+pkgdesc='PulseAudio emulation for ALSA'
+arch=('i686' 'x86_64')
+url='https://github.com/i-rinat/apulse'
+license=('custom:MIT')
+depends=('alsa-lib' 'glib2')
+makedepends=('cmake')
+install=apulse.install
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ 'asoundrc.sample')
+sha256sums=('f9ffbf7aff96680beff3243758e5c1e0d4ac9043d4bd6cbfb219890b4b91c9f3'
+ 'e851197ec9ebff528154210751cd6d5c426abfc2b1aa34343580407b1ea789a4')
+
+prepare() {
+ cd apulse-${pkgver}
+
+ mkdir -p build
+}
+
+build() {
+ cd apulse-${pkgver}/build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd apulse-${pkgver}/build
+
+ make DESTDIR="${pkgdir}/" install
+
+ # sample asoundrc
+ install -Dm644 ../../${source[1]} \
+ "${pkgdir}/usr/share/${pkgname}/${source[1]}"
+
+ # license
+ install -Dm644 ../LICENSE.MIT \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/apulse.install b/apulse.install
new file mode 100644
index 000000000000..ffc1cafd7b2b
--- /dev/null
+++ b/apulse.install
@@ -0,0 +1,13 @@
+post_install() {
+ cat << EOF
+
+For using PulseAudio emulation (ex. in skype):
+
+1. create a proper .asoundrc
+ $ cp /usr/share/apulse/asoundrc.sample ~/.asoundrc
+
+2. run apulse <program-name> [parameters]
+ $ apulse skype
+
+EOF
+}
diff --git a/asoundrc.sample b/asoundrc.sample
new file mode 100644
index 000000000000..b529dc7c1b18
--- /dev/null
+++ b/asoundrc.sample
@@ -0,0 +1,15 @@
+pcm.!default {
+ type plug
+ slave.pcm "asymed"
+}
+
+
+pcm.asymed {
+ type asym
+ playback.pcm {
+ @func getenv
+ vars [ ALSAPCM ]
+ default "dmix"
+ }
+ capture.pcm "dsnoop"
+}