summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:22:03 -0700
committerShadowKyogre2015-06-08 07:22:03 -0700
commit9578c38e011773bd58c3daa92976ef53800e95ad (patch)
tree45913a81649ecdbb357f85cf427c8c302ead2a18
downloadaur-9578c38e011773bd58c3daa92976ef53800e95ad.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e4a8365508c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = apwal
+ pkgdesc = Apwal is a simple application launcher for Linux together with a powerful editor.
+ pkgver = 0.4.5
+ pkgrel = 2
+ url = http://apwal.free.fr
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ source = http://apwal.free.fr/download/apwal-0.4.5.tar.gz
+ md5sums = 2f15a1a680f842d8373a1c2725b53130
+
+pkgname = apwal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..059f62b1f676
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# contributed by tomdeb <tomdeb@gmail.com>
+#
+pkgname=apwal
+pkgver=0.4.5
+pkgrel=2
+pkgdesc="Apwal is a simple application launcher for Linux together with a powerful editor. "
+url="http://apwal.free.fr"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('gtk2')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("http://apwal.free.fr/download/$pkgname-$pkgver.tar.gz")
+md5sums=('2f15a1a680f842d8373a1c2725b53130')
+
+build() {
+ cd "$srcdir/$pkgname"
+ make || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cd "$pkgdir/usr/bin"
+ cp "$srcdir/$pkgname/src/apwal" "$pkgdir/usr/bin/"
+ ln -s "apwal" "$pkgdir/usr/bin/apwal-editor"
+}