summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Isakov2023-08-01 15:10:11 +0600
committerKirill Isakov2023-08-01 15:10:11 +0600
commit779e771b0167a4e34b5184dd151449f19e0d7384 (patch)
tree8da74ba02380c28ae51aba2651bc674341d1ae28
parent911306b394516e5cae4a871b45fc54a52665c03b (diff)
downloadaur-779e771b0167a4e34b5184dd151449f19e0d7384.tar.gz
upgpkg: apx 1.8.2-2
use the correct image for `--apt` thanks to AUR user fortea for reporting it
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD45
3 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca80cc75aa99..dc5325c36c43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apx
- pkgdesc = Wrapper around multiple package managers to install packages and run commands inside a managed container
+ pkgdesc = Package manager with support for multiple sources
pkgver = 1.8.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Vanilla-OS/apx
arch = x86_64
arch = aarch64
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..81be5d92e399
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!.gitignore
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index 8e3515105e07..59a8b466f1f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,40 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: tarball <bootctl@gmail.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
+# Contributor: fortea
pkgname=apx
pkgver=1.8.2
-pkgrel=1
-pkgdesc='Wrapper around multiple package managers to install packages and run commands inside a managed container'
+pkgrel=2
+pkgdesc='Package manager with support for multiple sources'
arch=(x86_64 aarch64)
url='https://github.com/Vanilla-OS/apx'
license=(GPL3)
depends=(
- distrobox
- glibc
+ distrobox
+ glibc
)
makedepends=(go)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
b2sums=('615f1fce06db9e84f7ce1a421d60af5f4b3ad6de6faa2accd913b0520f46ce70285d959277bd90ec94febabd114279a1035535cfebc2c99ebf86271ace795cd1')
-prepare(){
- cd "${pkgname}-${pkgver}"
- mkdir -p build/
- sed -i 's|ubuntu|archlinux|g;s|apt|pacman|g;s|share/apx|bin|g' config/config.json
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ mkdir -p build/
+ sed -i 's|share/apx|bin|' config/config.json
}
build() {
- cd "${pkgname}-${pkgver}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build
-}
-
-check() {
- cd "${pkgname}-${pkgver}"
- go test
+ cd "${pkgname}-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "config/config.json" "${pkgdir}/etc/apx/config.json"
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "config/config.json" "${pkgdir}/etc/apx/config.json"
}