summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2023-04-04 13:03:01 +0200
committerPhilip Goto2023-04-04 13:03:01 +0200
commit978e9222d51566406ab0f65be5aa7b612014bee0 (patch)
tree73b807e8a30f2360b4fed0c5ac990659d554a6d1
downloadaur-978e9222d51566406ab0f65be5aa7b612014bee0.tar.gz
Initialize
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..939eaec73191
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = apx
+ pkgdesc = Wrapper around multiple package managers to install packages and run commands inside a managed container
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = https://github.com/Vanilla-OS/apx
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = go
+ depends = distrobox
+ depends = glibc
+ source = apx-1.8.1.tar.gz::https://github.com/Vanilla-OS/apx/archive/refs/tags/1.8.1.tar.gz
+ b2sums = bfec4cd8f8b7e1a866344f2d146309edaf6744c99fea0cfce570a9a48054112db880a4dcafe8472aa44cf4e8ce17ce92b3d8c2ed1b22ec05be67eb30009ddaed
+
+pkgname = apx
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d5653ad137b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=apx
+pkgver=1.8.1
+pkgrel=1
+pkgdesc='Wrapper around multiple package managers to install packages and run commands inside a managed container'
+arch=(x86_64 aarch64)
+url='https://github.com/Vanilla-OS/apx'
+license=(GPL3)
+depends=(
+ distrobox
+ glibc
+)
+makedepends=(go)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+b2sums=('bfec4cd8f8b7e1a866344f2d146309edaf6744c99fea0cfce570a9a48054112db880a4dcafe8472aa44cf4e8ce17ce92b3d8c2ed1b22ec05be67eb30009ddaed')
+
+prepare(){
+ cd "${pkgname}-${pkgver}"
+ mkdir -p build/
+ sed -i 's|ubuntu|archlinux|g;s|apt|pacman|g;s|share/apx|bin|g' config/config.json
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ go test
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "config/config.json" "${pkgdir}/etc/apx/config.json"
+}