summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjim36922023-01-07 23:06:39 +0200
committerjim36922023-01-07 23:06:39 +0200
commit29ff47e28fd49eeeb16dcf341aaab368531cddc2 (patch)
tree77cddb1390cc208382a313138998cdce40394df0
downloadaur-29ff47e28fd49eeeb16dcf341aaab368531cddc2.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD44
-rw-r--r--config.json6
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44d834fcbe8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = apx-git
+ pkgdesc = Vanilla OS package manager
+ pkgver = 1.4.0.r13.gd6805ba
+ pkgrel = 1
+ url = https://github.com/Vanilla-OS/apx
+ arch = x86_64
+ license = GPL3
+ makedepends = go>=1.17
+ depends = pacman>5
+ depends = git
+ depends = distrobox
+ provides = apx
+ conflicts = apx
+ options = !lto
+ source = apx::git+https://github.com/Vanilla-OS/apx.git#branch=main
+ source = config.json
+ sha256sums = SKIP
+ sha256sums = 972073c7a632d624091ab4b1f88b761ac3309ee137bef53de33e543154502e71
+
+pkgname = apx-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a75cbf91946f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+# Any
+*
+
+# self
+!/.gitignore
+
+# AUR required files
+!/PKGBUILD
+!/.SRCINFO
+
+# Source files
+!/config.json \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dc50eab4d72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: jim3692 <jim3692 at gmail.com>
+pkgname="apx-git"
+_pkgname="apx"
+pkgver=1.4.0.r13.gd6805ba
+pkgrel=1
+pkgdesc="Vanilla OS package manager"
+arch=('x86_64')
+url="https://github.com/Vanilla-OS/apx"
+license=('GPL3')
+depends=(
+ 'pacman>5'
+ 'git'
+ 'distrobox'
+ )
+makedepends=('go>=1.17')
+options=(!lto)
+conflicts=('apx')
+provides=('apx')
+source=(
+ 'apx::git+https://github.com/Vanilla-OS/apx.git#branch=main'
+ 'config.json'
+ )
+sha256sums=(
+ 'SKIP'
+ '972073c7a632d624091ab4b1f88b761ac3309ee137bef53de33e543154502e71'
+ )
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ go build -o apx main.go
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/apx" "$pkgdir/usr/bin/apx"
+ install -Dm644 "$srcdir/$_pkgname/man/apx.1" "$pkgdir/usr/share/man/man1/apx.1"
+ install -Dm644 "$srcdir/$_pkgname/man/es/apx.1" "$pkgdir/usr/share/man/es/man1/apx.1"
+
+ install -Dm644 "$srcdir/config.json" "$pkgdir/etc/apx/config.json"
+}
diff --git a/config.json b/config.json
new file mode 100644
index 000000000000..7cedfe332239
--- /dev/null
+++ b/config.json
@@ -0,0 +1,6 @@
+{
+ "containername": "apx_managed",
+ "image": "docker.io/library/ubuntu",
+ "pkgmanager": "apt",
+ "distroboxpath": "/usr/bin/distrobox"
+} \ No newline at end of file