summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian J. Bronner2019-09-26 17:51:28 +0200
committerSebastian J. Bronner2019-09-26 17:51:28 +0200
commit18537188ae844ab155040191475759842a7d36da (patch)
tree3a5f261698721264ea481965f3b25fbe73f8ff0e
downloadaur-18537188ae844ab155040191475759842a7d36da.tar.gz
Create aqbanking-git package
This was prompted by a sudden inability to connect to European banks due to PSD2 beginning 2019-09-14. PSD2 is not yet completely functional in the released version of aqbanking. See also gwenhywfar-git.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc8458e1716f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aqbanking-git
+ pkgdesc = A library for online banking and financial applications
+ pkgver = 5.99.35beta
+ pkgrel = 1
+ url = https://www.aquamaniac.de/rdm/projects/aqbanking
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = gwenhywfar-git
+ depends = ktoblzcheck
+ depends = libofx
+ provides = aqbanking
+ conflicts = aqbanking
+ options = !makeflags
+ source = git+https://git.aquamaniac.de/git/aqbanking
+ sha256sums = SKIP
+
+pkgname = aqbanking-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4bd1b8ff879b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.tar.xz
+/aqbanking/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74cd78dc6ec9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sebastian J. Bronner <waschtl@sbronner.com>
+
+pkgname=aqbanking-git
+pkgver=5.99.35beta
+pkgrel=1
+pkgdesc="A library for online banking and financial applications"
+arch=(x86_64 i686)
+url=https://www.aquamaniac.de/rdm/projects/aqbanking
+license=(GPL)
+depends=(gwenhywfar-git ktoblzcheck libofx)
+options=('!makeflags')
+provides=(aqbanking)
+conflicts=(aqbanking)
+source=(git+https://git.aquamaniac.de/git/aqbanking)
+sha256sums=(SKIP)
+_sourcedir=aqbanking
+
+pkgver() {
+ git -C $_sourcedir describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ ACLOCAL_FLAGS='-I /usr/share/aclocal' make -C $_sourcedir -fMakefile.cvs
+}
+
+build() {
+ $_sourcedir/configure --prefix=/usr --enable-gwenhywfar --with-backends="aqhbci aqofxconnect"
+ make
+}
+
+package() {
+ make DESTDIR=$pkgdir install
+}