summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-05-13 19:50:43 +0200
committerGeorg Schlisio2016-05-13 19:51:30 +0200
commit811797b2050b48b45f8caa1a98fb333a0dae4e99 (patch)
tree55d8fc0fc5f92dcfc61bdf41263bdd7f84e2ca0b
parentf97c7a36e806c819f31fd9f0799074093cf671ac (diff)
downloadaur-811797b2050b48b45f8caa1a98fb333a0dae4e99.tar.gz
version 0.9.1 - qt5, new design and much more
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
-rw-r--r--aqemu.patch14
3 files changed, 18 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e614b85e581c..dfb364e8bd3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
-# Generated by makepkg 5.0.0
-# Tue Feb 16 13:13:57 UTC 2016
pkgbase = aqemu
- pkgdesc = QEMU GUI written in Qt4
- pkgver = 0.8.2
- pkgrel = 5
- url = https://sourceforge.net/projects/aqemu/
+ pkgdesc = QEMU GUI written in Qt5
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/tobimensch/aqemu
arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
makedepends = qt5-base
depends = qemu
- depends = qt4
- depends = openssl
+ depends = qt5-base
depends = libvncserver
- source = https://downloads.sourceforge.net/aqemu/aqemu-0.8.2.tar.bz2
- source = aqemu.patch
- md5sums = dcec083f566e0a22df7bfe8e7ca4c593
- md5sums = 4f18e403b98b825a7582aab7c5c3e871
+ source = aqemu-0.9.1.tar.gz::https://github.com/tobimensch/aqemu/archive/v0.9.1.tar.gz
+ md5sums = d2540b513674d7242f112e222ba0fa2a
pkgname = aqemu
diff --git a/PKGBUILD b/PKGBUILD
index 50812cfe9e5e..54cf321cc0aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
pkgname=aqemu
-pkgver=0.8.2
-pkgrel=5
-pkgdesc="QEMU GUI written in Qt4"
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="QEMU GUI written in Qt5"
arch=('i686' 'x86_64')
-url="https://sourceforge.net/projects/aqemu/"
+url="https://github.com/tobimensch/aqemu"
license=('GPL2')
-depends=('qemu' 'qt4' 'openssl' 'libvncserver')
+depends=('qemu' 'qt5-base' 'libvncserver')
makedepends=('cmake' 'qt5-base')
-source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2 aqemu.patch)
-md5sums=('dcec083f566e0a22df7bfe8e7ca4c593' '4f18e403b98b825a7582aab7c5c3e871')
+source=("aqemu-$pkgver.tar.gz::https://github.com/tobimensch/aqemu/archive/v${pkgver}.tar.gz")
+md5sums=('d2540b513674d7242f112e222ba0fa2a')
build() {
- cd $srcdir/$pkgname-$pkgver
- patch -p1 -i $srcdir/aqemu.patch
+ cd "$srcdir/$pkgname-$pkgver"
cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DQT_QMAKE_EXECUTABLE=qmake4
make
}
- package() {
+package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}
diff --git a/aqemu.patch b/aqemu.patch
deleted file mode 100644
index e0efaabc273d..000000000000
--- a/aqemu.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -aur aqemu-0.8.2.pristine/Embedded_Display/vncview.cpp aqemu-0.8.2.new/Embedded_Display/vncview.cpp
---- aqemu-0.8.2.pristine/Embedded_Display/vncview.cpp 2010-02-26 14:40:40.000000000 +0100
-+++ aqemu-0.8.2.new/Embedded_Display/vncview.cpp 2012-02-29 22:50:52.816894769 +0100
-@@ -27,8 +27,8 @@
- #include <QMessageBox>
- #include <QInputDialog>
- #define KMessageBox QMessageBox
-- #define error(parent, message, caption) \
-- critical(parent, caption, message)
-+/* #define error(parent, message, caption) \
-+ critical(parent, caption, message)*/
- #else
- #include "settings.h"
- #include <KActionCollection>