summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2015-07-07 23:26:09 +0200
committerGeorg Schlisio2015-07-07 23:26:09 +0200
commitd097b731907103c3d1b4876868211a84ffe69a9a (patch)
tree2236fcfbc7c2aa68a23ee6d2980671f81c1262c5
downloadaur-d097b731907103c3d1b4876868211a84ffe69a9a.tar.gz
0.8.2, moved from aur3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--aqemu.patch14
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d726c8cedac3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = aqemu
+ pkgdesc = QEMU GUI written in Qt4
+ pkgver = 0.8.2
+ pkgrel = 4
+ url = http://sourceforge.net/projects/aqemu/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = qemu
+ depends = qt4
+ depends = openssl
+ depends = libvncserver
+ source = http://downloads.sourceforge.net/aqemu/aqemu-0.8.2.tar.bz2
+ source = aqemu.patch
+ md5sums = dcec083f566e0a22df7bfe8e7ca4c593
+ md5sums = 4f18e403b98b825a7582aab7c5c3e871
+
+pkgname = aqemu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99f905ed2148
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: schmoemi <schmoemi at arcor dot de>
+# Contributor: reMiND <detanator at gmail dot com>
+
+pkgname=aqemu
+pkgver=0.8.2
+pkgrel=4
+pkgdesc="QEMU GUI written in Qt4"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/aqemu/"
+license=('GPL2')
+depends=('qemu' 'qt4' 'openssl' 'libvncserver')
+makedepends=('cmake')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2 aqemu.patch)
+md5sums=('dcec083f566e0a22df7bfe8e7ca4c593' '4f18e403b98b825a7582aab7c5c3e871')
+
+build() {
+
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 -i $srcdir/aqemu.patch
+ cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DQT_QMAKE_EXECUTABLE=qmake4
+ make
+}
+
+ package() {
+
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file
diff --git a/aqemu.patch b/aqemu.patch
new file mode 100644
index 000000000000..e0efaabc273d
--- /dev/null
+++ b/aqemu.patch
@@ -0,0 +1,14 @@
+diff -aur aqemu-0.8.2.pristine/Embedded_Display/vncview.cpp aqemu-0.8.2.new/Embedded_Display/vncview.cpp
+--- aqemu-0.8.2.pristine/Embedded_Display/vncview.cpp 2010-02-26 14:40:40.000000000 +0100
++++ aqemu-0.8.2.new/Embedded_Display/vncview.cpp 2012-02-29 22:50:52.816894769 +0100
+@@ -27,8 +27,8 @@
+ #include <QMessageBox>
+ #include <QInputDialog>
+ #define KMessageBox QMessageBox
+- #define error(parent, message, caption) \
+- critical(parent, caption, message)
++/* #define error(parent, message, caption) \
++ critical(parent, caption, message)*/
+ #else
+ #include "settings.h"
+ #include <KActionCollection>