summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2016-07-23 21:14:57 +0200
committerLukáš Jirkovský2016-07-23 21:14:57 +0200
commit09b2c7a549b29d9f553228e516788f07e7a44b8a (patch)
tree9fe7edd422491f122672d58d53afd385a6df84dc
parent4f66ccecf0603c631f72dbd4d60c097f4506ba36 (diff)
downloadaur-aqsis.tar.gz
fix build (thanks to Thomas Ascher for the patch)
remove install file, as everything is now handled by hooks
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--aqsis.install14
-rw-r--r--shadowmap_old.patch20
4 files changed, 31 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce0475f7668e..7e6e888c106b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Dec 23 10:56:09 UTC 2015
+# Sat Jul 23 19:14:56 UTC 2016
pkgbase = aqsis
pkgdesc = A high quality, photorealistic, 3D rendering solution
pkgver = 1.8.2
- pkgrel = 3
+ pkgrel = 4
url = http://www.aqsis.org
- install = aqsis.install
arch = i686
arch = x86_64
license = GPL2
@@ -26,9 +25,11 @@ pkgbase = aqsis
source = http://downloads.sourceforge.net/project/aqsis/aqsis-source/1.8.2/aqsis-1.8.2.tar.gz
source = pfto.patch
source = imfinputfile-forward-declaration.diff
+ source = shadowmap_old.patch
md5sums = 399967e99f12cfbd1a7385c4e1d39c3b
md5sums = 908487f2e7b495b100dfa6b3aa8945ae
md5sums = e52f27d3041e88a63531b691ad05a6aa
+ md5sums = 9c490fa421b1c8b345741f06f7321b37
pkgname = aqsis
diff --git a/PKGBUILD b/PKGBUILD
index 5d630e7bfe9f..106a66556921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Gino Pezzin <pezzin@gmail.com>
pkgname=aqsis
pkgver=1.8.2
-pkgrel=3
+pkgrel=4
pkgdesc="A high quality, photorealistic, 3D rendering solution"
arch=('i686' 'x86_64')
url="http://www.aqsis.org"
@@ -11,13 +11,14 @@ optdepends=('qt4: graphical interface' 'libgl: ptview')
depends=('boost-libs' 'openexr' 'hicolor-icon-theme' 'shared-mime-info' 'desktop-file-utils')
makedepends=('cmake' 'boost' 'openexr' 'libpng' 'qt4' 'mesa')
options=('!libtool')
-install=aqsis.install
source=("http://downloads.sourceforge.net/project/aqsis/aqsis-source/$pkgver/$pkgname-$pkgver.tar.gz"
"pfto.patch"
- "imfinputfile-forward-declaration.diff")
+ "imfinputfile-forward-declaration.diff"
+ "shadowmap_old.patch")
md5sums=('399967e99f12cfbd1a7385c4e1d39c3b'
'908487f2e7b495b100dfa6b3aa8945ae'
- 'e52f27d3041e88a63531b691ad05a6aa')
+ 'e52f27d3041e88a63531b691ad05a6aa'
+ '9c490fa421b1c8b345741f06f7321b37')
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -25,6 +26,8 @@ prepare() {
patch -Np1 < "$srcdir/imfinputfile-forward-declaration.diff" || true
# fix build with boost 1.59
patch -Np1 < "$srcdir/pfto.patch"
+ # fix build for stricter iostream interface
+ patch -Np1 < "$srcdir/shadowmap_old.patch"
}
build() {
diff --git a/aqsis.install b/aqsis.install
deleted file mode 100644
index b2086e07b579..000000000000
--- a/aqsis.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor/
- update-mime-database usr/share/mime > /dev/null
- update-desktop-database -q
-}
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/shadowmap_old.patch b/shadowmap_old.patch
new file mode 100644
index 000000000000..9eddf61977b3
--- /dev/null
+++ b/shadowmap_old.patch
@@ -0,0 +1,20 @@
+diff -crB package.pristine/libs/core/texturing_old/shadowmap_old.cpp package.new/libs/core/texturing_old/shadowmap_old.cpp
+*** package.pristine/libs/core/texturing_old/shadowmap_old.cpp 2012-08-24 14:26:50.000000000 +0200
+--- package.new/libs/core/texturing_old/shadowmap_old.cpp 2016-07-12 22:53:04.498989000 +0200
+***************
+*** 176,182 ****
+ {
+ std::ifstream file( m_strName.c_str(), std::ios::in | std::ios::binary );
+
+! if ( file != NULL )
+ {
+ // Save a file type and version marker
+ TqPchar origHeader = tokenCast(ZFILE_HEADER);
+--- 176,182 ----
+ {
+ std::ifstream file( m_strName.c_str(), std::ios::in | std::ios::binary );
+
+! if ( file )
+ {
+ // Save a file type and version marker
+ TqPchar origHeader = tokenCast(ZFILE_HEADER);