summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 17:40:16 +0200
committersmls2015-07-09 17:40:16 +0200
commit910ff217cdb48125328455e7f1d680ac8e525f55 (patch)
tree4710cb730972c515b0d81b556a2181be97607e71
downloadaur-910ff217cdb48125328455e7f1d680ac8e525f55.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
-rw-r--r--aquaria-data-hib.install13
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9329fb02d953
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aquaria-data-hib
+ pkgdesc = A 2D fantasy action-adventure game (Humble Bundle version; game data only)
+ pkgver = 1.1.3+h20100504
+ pkgrel = 2
+ url = http://www.bit-blot.com/
+ install = aquaria-data-hib.install
+ arch = any
+ license = custom: "commercial"
+ makedepends = pngrim-git
+ provides = aquaria-data=1.1.3
+ source = hib://aquaria-lnx-humble-bundle.mojo.run
+ md5sums = 8b24ddeeb553e028bbd501102f891cc2
+
+pkgname = aquaria-data-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14cfd96f3808
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=aquaria-data-hib
+pkgver=1.1.3+h20100504
+pkgrel=2
+pkgdesc="A 2D fantasy action-adventure game (Humble Bundle version; game data only)"
+url='http://www.bit-blot.com/'
+arch=('any')
+license=('custom: "commercial"')
+makedepends=('pngrim-git')
+provides=('aquaria-data=1.1.3')
+install='aquaria-data-hib.install'
+PKGEXT='.pkg.tar.gz'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=('hib://aquaria-lnx-humble-bundle.mojo.run')
+md5sums=('8b24ddeeb553e028bbd501102f891cc2')
+
+build () {
+ cd $srcdir
+
+ # Remove binaries & libraries, and other redundant files
+ rm data/{aquaria,xdg-open,lib*}
+ rm data/README-linux.txt
+ rm -r data/gfx/nag
+
+ # Process PNG textures so that no white borders appear when zoomed out
+ msg2 "Fixing game textures..."
+ while read line; do echo -n '.'; done < <( # show progress as dots
+ find */ -name '*.png' | xargs pngrim
+ ); echo
+}
+
+package() {
+ cd $pkgdir
+
+ # Install game files
+ mkdir -p usr/share/aquaria
+ cp -rT "$srcdir/data" usr/share/aquaria
+
+ # Install documentation
+ mkdir -p usr/share/doc/aquaria
+ mv -T usr/share/aquaria/docs usr/share/doc/aquaria/original
+
+ # Install icon
+ install -Dm644 "$srcdir/data/aquaria.png" usr/share/pixmaps/aquaria.png
+}
diff --git a/aquaria-data-hib.install b/aquaria-data-hib.install
new file mode 100644
index 000000000000..140ae04b5bab
--- /dev/null
+++ b/aquaria-data-hib.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ if (! pacman -Qqs '^aquaria' | grep -vw 'data' >/dev/null); then
+ echo "Note:"
+ echo " | This package only provides the (proprietary) game data."
+ echo " | For the game executable, install one of the following packages:"
+ echo " | aquaria-git .. for the improved Open Source version"
+ fi
+}
+
+post_upgrade() {
+ post_install "$@"
+}