summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2016-02-15 18:23:10 +0100
committersmls2016-02-15 18:23:10 +0100
commit9cbe1e4b2ff29d4eb4bec18daf2b7069a582aabb (patch)
tree20860c752b4a27e4e5e54b19d927db486baa3c7d
parent7bdfdd0a0946c9f1c55007024bd02e9337fb5d82 (diff)
downloadaur-9cbe1e4b2ff29d4eb4bec18daf2b7069a582aabb.tar.gz
better post-install message; set AQUARIA_EXTRA_DATA_DIR
Users can now provide the data files in a custom location by setting AQUARIA_DATA_PATH.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--aquaria-ose.install23
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56668f74b0c1..85dc07465220 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Feb 15 10:45:21 UTC 2016
+# Mon Feb 15 17:21:33 UTC 2016
pkgbase = aquaria-ose
pkgdesc = A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = original v1.1.3 + many improvements)
pkgver = 1.1.3+o1.002
diff --git a/PKGBUILD b/PKGBUILD
index a8afed8fb4ef..ca9f149b094f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,28 @@ arch=('i686' 'x86_64')
license=('GPL')
depends=('sdl2' 'openal' 'gcc-libs')
makedepends=('cmake')
-optdepends=('aquaria-data-hib: Game data from the Humble Bundle release')
conflicts=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-hib' 'aquaria-git' 'aquaria-ose-git')
replaces=('aquaria')
+optdepends=('aquaria-data-hib: Game data from the Humble Bundle release')
install="$pkgname.install"
_repo=Aquaria
-_tag=OSE-v$_osever
+_tag="OSE-v$_osever"
source=("https://github.com/AquariaOSE/$_repo/archive/$_tag.tar.gz"
"aquaria-ose.desktop")
md5sums=('edb90261243611a20130b4bd9c2d6a13'
'0d1457aa0fae8ded40c011a7d766e46f')
-_folder=$_repo-$_tag
+_folder="$_repo-$_tag"
build() {
cd $_folder
+
+ # Patch (TODO: remove post-1.002)
+ awk -i inplace '{ print (102 == NR ? "// " : ""), $0; }' Aquaria/Main.cpp
+
+ # Compile
cmake -DAQUARIA_DEFAULT_DATA_DIR=/usr/share/aquaria \
+ -DAQUARIA_EXTRA_DATA_DIR=/usr/share/aquaria/override \
-DAQUARIA_OVERRIDE_VERSION_STRING="Aquaria OSE $_osever (based on Aquaria v1.1.3)" \
-DAQUARIA_USE_SDL2=1
make
diff --git a/aquaria-ose.install b/aquaria-ose.install
index 6fa99dfc5ec2..ac7c7d853848 100644
--- a/aquaria-ose.install
+++ b/aquaria-ose.install
@@ -1,13 +1,16 @@
post_install() {
- if (! pacman -Qqs '^aquaria-data' >/dev/null); then
- echo "Note:"
- echo " | This package only provides the game engine. You will also"
- echo " | need to install the proprietary game data, using one of the"
- echo " | aquaria-data-* packages."
- fi
-}
-
-post_upgrade() {
- post_install "$@"
+ cat <<END
+.--------------------------------------------------------------------.
+| This package only provides the (improved) game engine. |
+| To play it you also need to buy the original game data, e.g. from: |
+| - Humble Bundle <http://www.bit-blot.com/aquaria/buy.html> |
+| - GOG.com <http://www.gog.com/game/aquaria> |
+| - Steam <http://store.steampowered.com/app/24420> |
+| And then either: |
+| - Install the corresponding "aquaria-data-*" AUR package, or |
+| - Extract the game data to a custom directory and set the |
+| AQUARIA_DATA_PATH environment variable to it. |
+'--------------------------------------------------------------------'
+END
}