summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2015-09-07 00:19:16 +0200
committerFélix Piédallu2015-09-07 00:19:16 +0200
commit98a347ccc536d6c3ad9127662b617e1b226ffe6f (patch)
treeb06a0f574bc85358f983749489a508be64babe48
downloadaur-98a347ccc536d6c3ad9127662b617e1b226ffe6f.tar.gz
first version, does not work well.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD82
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10907c8d1de3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ar-sdk3-git
+ pkgdesc = The Parrot's AR SDK for Linux !
+ pkgver = ARSDK3_version_3_5.r135.gd4abf11
+ pkgrel = 1
+ url = https://github.com/Parrot-Developers/ARSDKBuildUtils.git
+ arch = any
+ groups = games
+ license = GPL
+ makedepends = git yasm jdk8-openjdk python-virtualenv
+ depends = boost-libs
+ depends = gcc-libs
+ source = git+https://github.com/Parrot-Developers/ARSDKBuildUtils.git
+ sha256sums = SKIP
+
+pkgname = ar-sdk3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84bf13be9d60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: Salamandar <felix@piedallu.me>
+pkgname=ar-sdk3-git
+pkgver=ARSDK3_version_3_5.r135.gd4abf11
+pkgrel=1
+pkgdesc="The Parrot's AR SDK for Linux !"
+arch=('any')
+license=('GPL')
+groups=('games')
+depends=()
+makedepends=('git yasm jdk8-openjdk python-virtualenv')
+depends=('boost-libs' 'gcc-libs')
+install=
+
+_gitname=ARSDKBuildUtils
+
+url="https://github.com/Parrot-Developers/$_gitname.git"
+source=("git+$url")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+
+ # Use Python2 instead of Python
+ virtualenv python2 --python=python2
+ source python2/bin/activate
+
+ cd "$_gitname"
+
+ # CheckEnv.py
+
+ if [ `./CheckEnv.py 2>/dev/null | grep Unix | awk '{print $3}' ` == "OK" ]
+ then
+ echo "Okay !"
+ else
+ echo "Error ! Restarting CheckEnv for info…"
+ ./CheckEnv.py
+ #return 1
+ fi
+
+ # Compiling
+
+ # This is needed because of the FORTIFY_SOURCE=2 of makepkg.
+ unset CPPFLAGS
+
+ ./SDK3Build.py -t Unix
+
+ # Use Python2 instead of Python
+ deactivate
+}
+
+check() {
+ echo "check"
+ # cd "$srcdir/$pkgname"
+ # make -k check
+}
+
+package() {
+ cd "$srcdir/$_gitname/Targets/Unix/Install"
+
+ mkdir -p "$pkgdir/usr/include"
+ cp -R include/libAR* "$pkgdir/usr/include"
+
+ mkdir -p "$pkgdir/usr/lib"
+ cp -R lib/libar* "$pkgdir/usr/lib"
+
+ cd "$srcdir/"
+
+ mkdir -p "$pkgdir/usr/share/doc/ar-sdk3"
+ cp -R Docs/* "$pkgdir/usr/share/doc/ar-sdk3"
+
+ mkdir -p "$pkgdir/usr/share/ar-sdk3"
+ cp -R Samples/ "$pkgdir/usr/share/ar-sdk3"
+
+}