summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorapicalium@gmail.com2022-11-05 20:58:29 +0300
committerapicalium@gmail.com2022-11-05 20:58:29 +0300
commitad087ea957369dac1de7d8f99cc9bd2f030021cb (patch)
tree3b32e3339cbc0f8d051e8d5001e192cb2de75511
downloadaur-ad087ea957369dac1de7d8f99cc9bd2f030021cb.tar.gz
Initial commit :: added everything
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD65
-rw-r--r--arachnowrap14
3 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aac8b78274b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = arachnotron-bin
+ pkgdesc = Cross platform, advanced Doom launcher built with QT.
+ pkgver = 1.1.4
+ pkgrel = 1
+ url = http://nephrite.uk/arachnotron
+ arch = x86_64
+ license = custom
+ makedepends = bash
+ depends = brotli
+ depends = bzip2
+ depends = double-conversion
+ depends = e2fsprogs
+ depends = freetype2
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = graphite
+ depends = harfbuzz
+ depends = icu
+ depends = keyutils
+ depends = krb5
+ depends = libcap
+ depends = libgcrypt
+ depends = libglvnd
+ depends = libgpg-error
+ depends = libpng
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = lz4
+ depends = md4c
+ depends = pcre2
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = systemd-libs
+ depends = xz
+ depends = zlib
+ depends = zstd
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols
+ provides = arachnotron
+ conflicts = arachnotron-git
+ source = http://nephrite.uk/storage/app/media/Doom/arachnotron-linux-lite-1.1.4.tar.gz
+ source = arachnowrap
+ sha256sums = 2653fcad69a97a7d3f9b96f6e0d80797f315592ffd15f1ab0d7045050fb935cf
+ sha256sums = 0ac7b8fd5497d73ca83ad2f6d0813d3fc49a15eb481ebe84fae9e8d4371fb19e
+
+pkgname = arachnotron-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8d398c82556
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Savchenko Dmitriy <apicalium@gmail.com>
+pkgname="arachnotron-bin"
+pkgver="1.1.4"
+pkgrel=1
+pkgdesc="Cross platform, advanced Doom launcher built with QT."
+arch=('x86_64')
+url="http://nephrite.uk/arachnotron"
+license=('custom')
+groups=()
+depends=(
+ 'brotli'
+ 'bzip2'
+ 'double-conversion'
+ 'e2fsprogs'
+ 'freetype2'
+ 'gcc-libs'
+ 'glib2'
+ 'glibc'
+ 'graphite'
+ 'harfbuzz'
+ 'icu'
+ 'keyutils'
+ 'krb5'
+ 'libcap'
+ 'libgcrypt'
+ 'libglvnd'
+ 'libgpg-error'
+ 'libpng'
+ 'libx11'
+ 'libxau'
+ 'libxcb'
+ 'libxdmcp'
+ 'lz4'
+ 'md4c'
+ 'pcre2'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'systemd-libs'
+ 'xz'
+ 'zlib'
+ 'zstd'
+ 'qt5-graphicaleffects'
+ 'qt5-quickcontrols'
+)
+makedepends=('bash')
+optdepends=()
+provides=('arachnotron')
+conflicts=('arachnotron-git')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://nephrite.uk/storage/app/media/Doom/arachnotron-linux-lite-$pkgver.tar.gz" "arachnowrap")
+noextract=()
+sha256sums=('2653fcad69a97a7d3f9b96f6e0d80797f315592ffd15f1ab0d7045050fb935cf'
+ '0ac7b8fd5497d73ca83ad2f6d0813d3fc49a15eb481ebe84fae9e8d4371fb19e')
+
+package() {
+ cd "$srcdir"
+ mkdir -pm 755 $pkgdir/opt/arachnotron
+ install -m 755 arachnotron $pkgdir/opt/arachnotron
+ cp -r --no-preserve=mode,ownership config $pkgdir/opt/arachnotron
+ install -D -m 755 arachnowrap $pkgdir/usr/bin/arachnotron
+}
diff --git a/arachnowrap b/arachnowrap
new file mode 100644
index 000000000000..5b490ab26164
--- /dev/null
+++ b/arachnowrap
@@ -0,0 +1,14 @@
+#!/usr/bin/bash
+export LOCALCFGPATH=$HOME/.config/arachnotron/
+export SYSTEMCFGPATH=/opt/arachnotron/
+export CFGDIRNAME=config/
+if test ! -d $LOCALCFGPATH
+then
+ mkdir -p $LOCALCFGPATH
+fi
+if test ! -d $LOCALCFGPATH/$CFGDIRNAME
+then
+ cp -r --no-preserve=mode,ownership $SYSTEMCFGPATH/$CFGDIRNAME $LOCALCFGPATH
+fi
+cd $LOCALCFGPATH
+$SYSTEMCFGPATH/arachnotron