aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Williamson2017-09-14 10:39:18 -0400
committerMike Williamson2017-09-14 11:05:35 -0400
commit09bb197ad0e085033229cd0072077aba519912f0 (patch)
tree25141b4a8842059b7ca43c6d2a54262485c1ca26
parentc1844f5eb8a15caa191c1029123f6f2ef34bddf1 (diff)
downloadaur-09bb197ad0e085033229cd0072077aba519912f0.tar.gz
Switch to Clang for compiling.
This seems like a good move in light of this: https://www.archlinux.org/todo/gcc5-removal/
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 488c1e3ec2ff..57cffcadd0e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=arangodb
pkgver=3.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="A multi-model NoSQL database, combining key-value, document and graph data models."
arch=("i686" "x86_64")
url="https://www.arangodb.com/"
license=("APACHE")
depends=("openssl" "systemd" "curl" "zlib")
-makedepends=("cmake" "gcc5" "python2" "linux-api-headers")
+makedepends=("cmake" "clang" "python2" "linux-api-headers")
options=()
install=arangodb.install
source=("https://www.arangodb.com/repositories/Source/ArangoDB-$pkgver.tar.bz2"
@@ -29,8 +29,8 @@ build() {
export PATH="`pwd`:$PATH"
export LD="ld.gold"
# I'm not proud of this but currently it's the only way to compile this.
- export CC="gcc-5"
- export CXX="g++-5"
+ export CC="clang"
+ export CXX="clang++"
msg2 "Configuring ArangoDB."
cd $srcdir/ArangoDB-$pkgver