aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Williamson2017-07-21 07:30:33 -0400
committerMike Williamson2017-07-21 07:30:33 -0400
commit666e08009ad9bd6d64acf94ae79bb411280fb912 (patch)
treea4c67052f3d77147aaef97ebd672fa206912d0b4
parent9bc13bc6b534395d1f9d3867f1ff7a8cb7ebe9ae (diff)
downloadaur-666e08009ad9bd6d64acf94ae79bb411280fb912.tar.gz
Add gcc5 as a make dep
This is a workaround to the problem of not being able to compile with the current gcc.
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2dfe43e50e0..ab0d20f97846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=("i686" "x86_64")
url="https://www.arangodb.com/"
license=('APACHE')
depends=('openssl' 'systemd' 'curl' 'zlib')
-makedepends=("cmake" "python2")
+makedepends=("cmake" "gcc5" "python2")
options=()
install=arangodb.install
source=("https://www.arangodb.com/repositories/Source/ArangoDB-$pkgver.tar.bz2"
@@ -28,6 +28,9 @@ build() {
ln -s -f /usr/bin/python2 python
export PATH="`pwd`:$PATH"
export LD="ld.gold"
+ # I'm not proud of this but currently it's the only way to compile this.
+ export CC="gcc-5"
+ export CXX="g++-5"
msg2 "Configuring ArangoDB."
cd $srcdir/ArangoDB-$pkgver